Z-wave device (GE ZW1001 outlet) stopped communicating status to the hub after platform update

After updating my C-8 hub platform from 2.3.8.117 to 2.3.8.118, my oldest z-wave device (GE ZW1001 outlet) stopped communicating status to the hub. I can turn it on and off but the device status never updates. It worked fine using the "Generic Z-Wave Outlet" driver but no longer after the update. I tried a z-wave repair, but that did not help. The device has a good signal (RSSI: 23 dB). All of my other devices work just fine. Did the "Generic Z-Wave Outlet" driver get changed in some way with the platform update?

I'm not aware of any changes. (If you do suspect something, you can always use the Diagnostic Tool to downgrade and see if it helps.)

One likely oddity of this device, and one I don't see mentioned in your post anywhere, so I'm not sure if you're aware: this is an old enough "classic" Z-Wave device that it probably never reports status from phyiscal changes back to the hub on its own. Are you only seeing this with those (i.e., if you go to the switch on the wall and turn it on or off), or are you also seeing it after commands from the hub? It should always update after the latter--this problem is restricted to the former.

This would happen on any hub platform version. Workarounds include polling, though this is generally preferable to avoid if possible due to the traffic it creates; using this device only in automations from the hub (so you never have to worry about physical changes); or just dealing with the fact that this can happen (e.g., if you have no automations on the hub that depend on the state of this device).

1 Like

Thank you for your feedback. I followed your suggestion to downgrade and the issue was still present. I can manually switch the device or command it from the hub and neither provide any status change at the hub. I loaded the Hubitat Polling App but it will not list the outlet switch using my selected driver. My memory may be playing games with me or the device has failed in some manner. Instead of spending allot of time dealing with this, I am going to replace the device with something using a newer 800 series chip. Thanks again for your response.

2 Likes