Yet another ghost device problem...don't understand why backups seem to restore this device

I have a Z-Wave device that refuses to be deleted.

I've tried a bunch of things, however the one I have question on is:

  • I restored a database where the offending device was still paired. The device however will not connect as it has been factory reset.
  • I Forced removed the device (ID 3E)
  • I rebooted and the device was not in the Z-Wave device list but it remained on the Settings \ Z-Wave list.

Any thoughts?


I've tried:

  • Z-Wave repair then remove when it sometimes is an option
  • Shut down and retried the above.
  • Shut down the hub, wrapped it two layers of aluminum foil (the purpose would be to simulate all the other Z-Wave devices being off). Rebooted and tried various delete methods.
  • I know the device this ghost was. I loaded an old database, this database shows the Z-Wave details but I cannot delete it. I cannot reconnect because that device has been factory reset.

It's not too surprising that the Z-Wave Details list and your Devices list are different after restoring backups from different times--the Devices list is affected by what your hub database thinks , while Z-Wave Details is a reflection of the Z-Wave radio database. These are separate entities. The hub database is what is contained in a backups, and it is affected by soft resets or restores. The Z-Wave radio contents are not contained in these backups (except Hub Protect backups, if you choose to use that service) and is also not affected by a hub database restore (again, unless you restore a Hub Protect backup and specifically choose that option--but that's not what most people mean when they say backup or restore).

Additionally, a "Force Remove" just removes the Hubitat device (from the Devices list or hub database), but it doesn't touch the Z-Wave radio. If the device is functional, a "proper" exclusion, which is offered first, should work and would address both; this is specific to the "Force Remove" and explains the other thing you observed. This is also why it's only recommended as a last resort.

Going back to the actual problem you're asking about, the first thing I'd try is also the least fun: patience. :slight_smile: Waiting a day or two and then trying the removal again may make it work on its own. The next time you'd try (and, again, I'd wait before trying) is keeping Logs open while you try and see if any entries are generated for "Hub" or "sys:1" that might give clues as to why it doesn't work if it still doesn't work--but after waiting a while, it just might.



Thank you for your detailed explanation. I kind of figured the radio DB and the Hub DB were separate which was why I went back to an old Hub DB hoping if I could delete it there it would stay deleted when I installed the current Hub DB.

I know you said "wait", and I will, however I've been doing this for about 2 months, trying to delete it every week or so. In each case the browser screen on the settings/Z-Wave page show basically the same as the below. I'm not familiar with the sys1 Z-Wave messages but I don't see any entry like "node 3E deleted" which I would think would be present.


I would say that the real device is still powered up and the hub mistakenly thinks that it should not be removed because it is still communicating. I would start by turning off the whole house (at least the circuits with Z-wave switches), and powering up just the hub and your router so you can access the hub.

I can't remember if you said you did or did not have a Z-stick of some type. Often that is the easiest way to remove a stubborn ghost, but admittedly that does cost maybe $25 or so. The Z-stick comes in handy for other things, so I think it is worth having one around just becuase.

If you don't want to do any of that, could you take the hub to work, a neighbors, your relatives home, or somewhere where the hub cannot possibly talk to your Z-wave devices?

That happens sometimes, but the only log available seems to suggest the opposite. What would be nice to have is the one from the time when it's trying to be excluded, though.

1 Like

One other quick question, did you do the Z-wave firmware update when it came out a couple months ago? It would be on the top left of the Zwave details page. (Don't mistake it for the similar button in the right upper corner) If you don't see that Firmware Update button, you are up to date.

1 Like

Thanks for the reply(s).

The removed device is NOT powered.
I have updated the Z-Wave firmware (some time ago). I do not recall if this device was removed before or after the firmware update.

I tried the turn off all Z-Wave devices path. Only instead of turning off the devices I wrapped the hub in aluminum foil (two layers of heavy duty). On restarting (I shutdown to add the foil), no Z-Wave devices were reachable and the "Hubitat Z-Wave Mesh Details" app showed no radio signals.

I then tried to remove the offending 0E device. No good. I then removed a device 62 which was successful.
Device 62 was the exact same device as the 0E device, I re-paired it to see if it my afford some new opportunity (it didn't or I couldn't find it). This is an OLD Leviton dimmer module that is finicky about pairing/excluding.

So does anyone know what 0 SDK failure is?


Brian, It seems I have the same issue as this post you responded to.

I have a C7.

It would seem the only way to "fix" this is to completely reset the Z-Wave radio. Is this correct?

I would imagine I could use my "Z stick S2" to exclude all the devices. Similar to my C4 to C7 upgrade.

So you see anything I'm missing?


BTW you might have a "ghost node" category added under on of the help topics.

Did you try removing the ghost using that stick?

No I've not tried to remove a ghost. I have excluded many devices but no ghosts.

I've read to do so requires a Silicon Labs download. I looked into that some years ago for other reasons and didn't pursue it.

I'm also concerned that a corrupt database may have more issues than just this ghost.

I'll have to look and see if that is the only option.


I installed Simple Studio V4 and PC Controller.

I had the PC Controller show up in the Z-Wave list. Could see the offending entry in the PC Controller.
Yet it would not change the node (62) to "is failed".

At the moment this ghost node doesn't seem to be an issue for the Hub. It bugs the .... out of me.
I am also concerned; if this is a corrupt database, It won't heal it self and I suspect it may get worse in the future.