Yale YRD256 - not showing unlocked

Today I paired a new Yale YRD256 lock to my HE7... my dashboard shows the lock as "locked" but when we unlock the door (manually or by code), the status on my dashboard does not change. Also, if I click on the dashboard icon to unlock the door, I hear the door unlock but the dashboard shows the "hour glass" and never shows unlocked. Anyone have any ideas how to fix this situation?

Try locking/unlocking and watch the lock status from the device settings page rather than a dashboard.

That can help distinguish whether it’s an issue with the device itself or the dashboard.

Does it have a z-wave or zigbee module?

1 Like

@marktheknife... thanks for the suggestion. When I lock it from the Device page, everything is correct and the door is locked. When I unlock it from the Device page, the lock does unlock but the status on the Device page still shows it locked.


1 Like

Oops... Z-Wave

The lack of reporting is most often a mesh issue. How robust is your z-wave mesh?


1 Like

I believe I have a robust Z-Wave mesh... I don't have any reporting issues with any other Z-Wave devices and in the case of the Yale lock, I have 2 Inovelli Red switches within 5 feet but I'll do more testing & monitor of the logs

I was about to log the exact same issue when I found this thread.

What's odd is I have two YRD256 locks using the same driver, etc., but only the one on the garage entry door has the issue of not reporting its status. I have to go to the Devices page and hit refresh to sync up both the dashboard and the device status on the Devices page.

FWIW I also have an older Yale YRD120 that is working fine using the same "Generic Z-Wave Lock" driver.

Back to the faulty YRD256 lock, another oddity is when the garage lock is locked or unlocked from the Devices page or dashboard, there is no log activity until I manually hit refresh. The logs act as expected for the working YRD256 and YRD120.

Lock Code Manager shows no activity for the garage lock, while the other two are recorded correctly.

The problem child is several years old with a new Z-Wave module, while the working YRD256 is brand new and came from the factory with a Z-Wave module; I doubt that matters but who knows.

The mesh seems solid with several other devices in the garage working properly. The batteries are fresh and the lock reports 100% battery power.

I swapped the Z-Wave modules between the two YRD256s; they didn't like that at all. No response on the garage lock using the other module, and then the good lock completely quit working with its original module for about 20 minutes. Z-Wave repair didn't help. Luckily it came back to life. The modules must code themselves to the lock hardware.

So after the module swap debacle I'm back to where I started with one working YRD256 and one that fails to report its status.

Any ideas? TIA

Well, this is a little kludgy but it seems to work. I added a virtual lock to control the misbehaving physical lock, wait 3 seconds, and force a refresh.

Have you all checked this out. Perfect solution for me.

1 Like

I installed Reliable Locks. It was worth a shot but still no cigar. The lock just isn't firing the notifications. Changing the lock manually doesn't notify the hub so that's a problem. And a significant number of times the lock still doesn't report the correct status when actuated from the dashboard or device page.

If I can return the new Z-Wave module I'll swap it for a Zigbee and see what happens.


oh yeah. If it's not sending manual events, you're just going to be out of luck. Switching to zigbee should fix it though.

1 Like

For the archives, Yale swapped the Z-Wave module for a Zigbee at no cost. The Zigbee is working perfectly in the existing YRD256 lock.

BTW, Lock Manager is a great built-in app.


+1 - That has been my experience as well.. with the same lock. Glad everything is working!!!