Yale Assure SL - getCodes command returns nothing

As the title says, I have had a Yale Assure Sl ( Z-wave module ) lock for a few months now. I wanted to look up which codes were programmed as I wanted to change one but forgot its position. Previously when I clicked getCodes, the available lock codes would display in the UI. Now, it does nothing. Well not nothing, the request gets sent but nothing shows up.

There is a but of status on the side that says lockCodes, but it is al in mixed up alphanumerics. I assume these are hashed versions of the lock codes, but I don't se a way to de-encrypt them and get the position like the getCodes command used to return and display.

Has anyone seen or solved this problem?

Might try something like

codeString = decrypt((String)device.getCodes())

In the driver details uncheck and save the encrypt lock codes preference.

Driver details? I was not using a driver for the lock as I could not find one that matched the model I was using. I might not have looked hard enough, or just missed it, but if you have a link to a driver I could use I would apply it.

Also if there is another area for driver details let me know. I am still getting used to hubitat and haven't found all the buttons.

would this go in the driver code section or just the Advanced input field to send command?

It would go in the code, but to get back to Mike’s suggestion I’d try the generic Zigbee or Zwave driver depending to see if it worked first.

Pardon the ignorant question, but where would I find the generic driver? Nothing exists in the Driver Codes section that has that name. I know that the yale lock defaults to Generic Lock, but never saw a specific driver that controlled this so I just assumed it was part of the platform code somewhere inaccessible.

Driver Code is for Community Developed code.. there's also built-in Drivers and Apps.

Just go to the Device Info page for your device and pick a driver from the drop down lost. If you have code in Driver Code section, those drivers would appear at the end of the drop down list. Everything else is Built-In.

Screen Shot 2021-11-27 at 10.15.36 AM

Clicking on Type, becomes:

Screen Shot 2021-11-27 at 10.15.57 AM

1 Like

A combination of this and finding that there is an app called Lock Code Manager, helped me solve the problem. Switching back to the Generic Z-Wave Lock type also brought up the option to decrypt the lock codes.

Thanks for all the helpful suggestions.

Download the Hubitat app