Yagusmart 4 button Scene Switch

So just received the Yagusmart 4 button Scene Switch, using the Zemismart-zigbee-button-remote driver I modified it for 4 buttons and it works a treat, the Scene Switch is only

£14.99 from Amazon uses a CR2430 battery which apparently lasts 730 days, we will see, it looks well made and so far hasnt dropped off the network, again we shall see.

4 Likes

Hi Peter, I algo got one of this but, to be honest, I could not even paired with HE... Did you just press the first button and that is?
Also about the drive, do you mind to share it ? Thank you in advance, Daniel

I'm using this driver and the device is working flawllesly: GitHub

Note that my device isn't from Zemismart - its brand is Lonsonho -, but it works!

1 Like

My device is Yagusmart, the no 1 button is the button on the bottom left, you hold this for 10 seconds and it the goes into pairing mode, I then used the Zemismart-zigbee-button-remote driver and modified it for 4 buttons as below from line 91 this has been modified as well to give the button mapping on the device as button 1 top left, button 2 bottom left, button 3 top right and button 4 bottom right.

def parse(String description) {
if ((description?.startsWith("catchall:")) || (description?.startsWith("read attr -"))) {
    def parsedMap = zigbee.parseDescriptionAsMap(description)
    if (debugEnable){
        log.debug("Message Map: '$parsedMap'")
    }
    switch(parsedMap.sourceEndpoint) {
        case "04": 
            button = "1"
            break
        case "03": 
            button = "3"
            break
        case "02": 
            button = "4"
            break
        case "01": 
            button = "2"
            break
    }
    switch(parsedMap.data) {
        case "[00]": 
            name = "pushed" 
            break
        case "[01]": 
            name = "doubleTapped" 
            break
        case "[02]": 
            name = "held" 
            break
}
    sendEvent(name: name, value: button, descriptionText: "Button $button was $name",isStateChange:true)
}
return

Just a quick update, 7 days in and the switch has performed flawlessly, no drop offs. But for some strange reason here in the UK you can only buy the 4 button version.

1 Like

Thanks for this. I have a few of the remotec scene master scene masters (8-button) which work really well (and just ordered a few more). I also want something with fewer buttons and had quickly looked at this on Amazon. But the pic of the woman in bed put me off (it make it look the size of a dinner plate). Just checked again and it is perfect size to put one on each bedside cabinet. £27 for 8 buttons (half the price of 8 buttons with the remotec). Cheers :slight_smile:

Thanks for this post, this helped me get my 'Tuya' version of this switch / button working (https://www.ebay.co.uk/itm/Tuya-Smart-ZigBee-Wireless-Free-Sticker-4-way-Panel-Scene-Button-Switch-UK/284094366128?) .

I also modified the code to match the model and manufacturer number. I am having an issue with using rule machine and loading it as a button device and showing all the 4 button functions. How are you programing the functionality of the buttons?

For my Philips hue button I use 1 rule to control all 4 buttons (X3 states). I was hoping I could do the same for this 4 buttons (x3 states - press, double press and hold).

When I select the button device it shows like this? Any pointers?

If I define a rule using Button Device i get this:

I then select prefill all button actions for say pushed

and you get:

You can add the differant functions from here or use the button not the button device this gives you:

1 Like

Products like this will be the death of my bank account...

1 Like

Thanks for the screen shots Peter,

I also inquired on some other posts and I was advised there was an error in the driver code. which you may have already corrected 'private sendButtonNumber()' was missing the '()' in the version I have so the configure option was not identifying the 4 buttons. This was the cause of my problem.

Working now and added my modified code here: https://github.com/GTI-140/Hubitat/blob/main/Tuya_Zemismart_4_switch I changed the order from top left to bottom right : 1,2,3,4.

I think ill be ordering a few more of these and might try a mains powered product now I am getting somewhere with the code, even thought still very much a beginner.

1 Like

This device looked promising so I've bought one to test (here).

The information on it is very scarce currently so I'll add some more here.

It is sold under many brands: Earda, Zemismart, Losonho, Yagusmart and probably even more. (I really don't get Chinese branding strategies!)
The model is ESW-0ZAA-EU, @peter , could you please confirm if yours is the same and put it in the title? Since there is this brand mess, it is hard to find information based on the brand only.

The fingerprint I've used in a draft driver I wrote is:

fingerprint deviceJoinName: "Zemismart 4 Button Remote (ESW-0ZAA-EU)", model: "TS0044", inClusters: "0000,0001,0006", outClusters: "0019,000A", manufacturer: "_TZ3000_vp6clf9d", profileId: "0104", endpointId: "01", application: "43"

I've found a Polish forum (thanks Google Translate) where people complained about it not sending commands after not being used for a while. I didn't use it much and didn't experience that problem.
Although the battery model is CR2430, it worked well with a CR2025 that I had in hand, and will certainly work with other similar 3V coin batteries.

The long press time is a no go for me, 5 seconds!!!
In my opinion it should be 2 seconds max.
With that problem I consider it to have 2 functions per button, a total of 8 functions, it is hard to compete with Aqara Opple with its 6 buttons and 4 functions each! I find the Aqara design not as good though.
I'm no expert in devices, HE and Zigbee, just starting. Maybe someone more experienced could find out if there is a command to send to it to configure the long press time.

I've disassembled it completely and its buttons are the same used on regular Mice. The finish on the LED light insertions seem be hand made and are not great, but you can only notice it if you look really close.
Here are some pictures of it.

Is there any chance this driver would work for the wired Tuya buttons also? I've ordered some to try, so basically wondering if these would work or if there are others available in some thread I haven't yet found :grinning:

I would be very surprised if it did.

Pete

Does anyone have a driver that reports battery on these? I'm using @nealephoto's driver from post 9 which works great but I don't get any battery info.

Its only going to report battery when it wants to, and I have no idea when it wants to.

It did not support the standard Zigbee battery level interval parameters.
The device also does a hard sleep, meaning it doesn't check in for commands per ZHA spec...

The good news is that battery life should be awesome...

1 Like

Unfortunately all these variants seem to have all sorts of different behaviours :frowning:

My 4-button doesn't accept any configuration for battery reporting, but reports battery percentage every time button 1 is pressed (bottom left).

Whereas my 3-button accepts configuration for the battery percentage attribute OK and appears to adhere to it.

My 2-button and 1-button versions don't do either of the above, but occasionally, seemingly randomly, they do report battery percentage.

Nicely consistent!

What Driver are you using Martyn? I have a couple of the 4 button devices and they don't have any battery information showing at all.

I'm currently using mine with deCONZ.

Looking at the driver you're using from post 9, if you enable debug logging do you get anything logged for Cluster 0001 and Attribute 0021 when you press any of the buttons, or periodically?

That driver isn't currently "doing" anything even if it did receive battery reports, but seeing if your device is actually sending them would still be visible in the logs.

Based on what Mike mentioned above, it sounds like the built in driver should report battery if / when the device sends them, so you could try that.

To be honest I hadn't realised there was a built in driver for this, there is nothing in the compatible docs list that I could find, but I've just tried adding one to my spare hub (with no custom driver installed) and it picked it up as "Tuya Zigbee Scene Switch" and works great with single and double tap detected and battery reporting at 100%. As you found, it seems to update the battery on the press of button 1.

I've no idea how long the driver has been on for this but good work @mike.maxwell and the Hubitat team!

Yeah it was in the 2.2.5 release notes, unfortunately I think the compatible devices list lags behind a bit until somebody gets round to updating it.

I don't think Mike implemented the held event because it's something like 5+ seconds to trigger it, which isn't really usable for most applications.

1 Like

Download the Hubitat app