Xiaomi Button - Need Driver

Thought that i would try out ordering cheap devices from Ali Express.
The Xiaomi buttons were well reviewed, so ordered two.

Now, I cannot find a driver to get them to work!
Have tried the Xiaomi Button driver (no luck) and the driver set from OLL.

No good so far.
Any suggestions?

What's the model number? Perhaps it is supported by @chirpy's driver for Xiaomi Mijia/Aqara devices.

1 Like

The model number of the device is: WXKG01LM

That should work with @chirpy's driver.

This is what I get with @chirpy driver:
image

It seems like any driver I use, I get the numberOfButtons:0

Any ideas?

Is there a configure or initialise command in the driver? If so you might need to click on that button.

There is a configure button, but nothing happens.

Another driver I tried stated there were 5 buttons, but again, nothing worked.

Try this driver https://github.com/markus-li/Hubitat/blob/release/drivers/expanded/zigbee-xiaomi-aqara-opple-button-switch-remote-expanded.groovy. This is what I currently use.

1 Like

Thanks for that.
I think I found the issue - the first button wasn't identified correctly.
Will re-pair the first one, then try that driver.

Download the Hubitat app