Xenon 4-gang + 2 USB extension, Unable to switch off individual sockets

  • endpointId: 01
  • application: 43
  • isMultiEP: true
  • manufacturer: _TZ3000_o005nuxx
  • model: TS011F

Its a totally different one ...

1 Like

They should give them all different names then not force us to wait till after we've bought them to find out :frowning:


They have already done it - the manufacturer of _TZ3000_o005nuxx is charged a monthly/annually fee by Tuya corporation for using their cloud services from a different business account than the manufacturer of _TZ3000_cfnprab5 device. :slight_smile:

When these devices are used with Tuya zigbee gateway, the end user will see no difference, because Tuya pushes from the cloud the correct driver for each device, based on their manufacturer ID.

1 Like

As it happens I haven't found the device any more satisfying than just buying a dumb strip and putting in smart plugs where required. Took me ages to think of a good place to use it, too.

If you want to experiment, you can do the following:

  • manually assign any of my Tuya drivers and click on the Configure or Initialize button. You can try with the Tuya Zigbee metering plug for example. The driver will not control individually the switches but will initialize the Tuya device properly, spelling the TuyaMagic() towards the device.
  • manually switch to HE inbuilt 'device' driver and delete/clean up all states that will be created by the first driver.
  • finally switch to the inbuilt "Generic Zigbee Multi-Endpoint Switch" and check if it is working

I still have one of my first 'smart' devices - an WiFi Broadlink 4-gang extension.
And I still don't have practical use of the individual switches for each of the 4 sockets. What I was thinking lately is to move it to the rack where is my WiFi router, the main C7 hub, the Philips Hue bridge, etc.. This will allow me to have a second and independent from HE way to reboot some devices - from Alexa as an example.

1 Like

Thanks kkossev, your suggestion worked.
I can control the sockets individually :slight_smile:

  • endpointId: 01
  • application: 43
  • inClusters: 0003,0004,0005,0006,E000,E001,0000
  • isMultiEP: true
  • manufacturer: _TZ3000_cfnprab5
  • model: TS011F
  • outClusters: 0019,000A
  • softwareBuild:
1 Like

Mine is the same as @kkossev which is odd because there was a choice of 2 zigbee strips on amazon and it was @Inge_Jones answer to a customer question that made me choose this.
I would have taken a chance anyway. But is odd we bought it from the same place.

form me it was to replace 4 outlets I need to switch individually, but I have to use a 6 way strip to fit them on. i thought this would be better than buying a new 6 way strip that I need.

Did you try the workaround from the post above?

1 Like

This worked for me too. I never would have thought to do that.

1 Like

Just did, I was working do the thread. Thanks.

1 Like

On Amazon, sellers seem to share item pages. So if a seller thinks "Ah yes that looks like what I am selling" they can piggyback onto that item, and you might get a random seller of an item that is different from the random seller I got. If the seller is unscrupulous you can get something vastly different to the original entry as I found out when buying wrapping paper for xmas one year.

1 Like

Mine just arrived, same as yours. What a faff to get it working!


Sorry for my total lack of competence, but I am trying to make this power strip work, and with many attempts and recommendations from you I am not getting it.

I will try to describe below my step by step, and see if you can help me identify what I'm doing wrong.

First step is to add the device to HE: Devices > Add Devices > Find by device type > Switches > Generic/Other > Generic Zigbee Multi-Endpoints Switch > +Add > + Start Zigbee pair > press the power button on the strip until it blinks blue and the message Found a Zigbee device, initializing appears...

I add a device name > Next
Choose a room > Next
View Device details

I then have the following screen.

I then change the Type that has "Device" as drive, to the "Tuya Zigbee Metering Plug" drive > Save Device

The following screen appears.

Then I pressed the Initialize button. The following information is updated on the screen.


As instructed above, I now switch from the "Tuya..." drive to the "Device" drive > Save Device.

Below is the new screen, and according to the instruction I press the "Delete All Current Sates" button

I am now looking to change the drive that is currently "Device" to "Generic Zigbee Multi-Endpoint Switch" again > Save Device

The screen below resulted, and no child device was created in the process.

No device child was created.

In an attempt to do something different, after all the above procedure, without deleting the device already created, I repeat Add Device > Find by device type > Switches > Generic/Other > Generic Zigbee Multi-Endpoints Switch > +Add > + Start Zigbee pair > and at this point it created the children.

When I enter the device, I see the screen below, but I can't make any commands, it won't turn on or off. Two things caught my attention.

The main device has the Device Network ID below FB02 , and see that the child (screen above has the number 1883-01 to 1883-05.


Another issue is that it doesn't allow me to change the Drive type, I saw in an example above that the son used the same drive as the father, but in my case it is as Generic Component Switch, I don't know if this would interfere.

In short, I can't make any headway with several different attempts. Sorry @kkossev for the long post, but I went through as much detail as possible to see if I can get any help.


1 Like

When you went to multi-endpiont switch, did you click on configure after save? your device shows the state variables which I don't have. Everything else looks ok.

I am thinking about how to make all this process simpler.... Using the 'Tuya Zigbee Metering Plug' driver is not the best solution, it is not intended to control multi-gang switches and it adds a lot of state variables that are not needed for a 4-gang extension device. Probably, creating a new simple driver which will just initialize the Tuya device properly, without leaving any additional state variables.

I don't have such a multi gang extension plug, so I don't know whether there isn't any other community driver that is better suited. All that is needed to make it work with Tuya devices is adding a single line of code... Wasn't there some custom drivers written for the Australian market?

@WMarcolin see the issues with the same weird device that were encountered here...

It will be too much time-consuming and risky to continue without having the actual device to test in a development/test environment, so for now, I give up : (

Download the Hubitat app