Worked, not half my devices are unresponsive

So I cut over from Smartthings the other day and had basically everything working. I expected to have to do some troubleshooting which was ok and something I was going to tackle over the next few days.

The problem I'm having is now a number of my devices, light switches, motion sensors, and plugs, are unresponsive. No big deal, exclude and re-include and try again right? I was able to successfully do this once or twice, but now it won't let me exclude the devices at all.

Any ideas?

Welcome.

Where are you trying to exclude? Doesn’t need to be one or the other hub. Z-Wave devices can be excluded via either hub.

If you had response and then none, you should look at how your Mesh is built, and how you’re rebuilding it. You should not need exclude and re-include multiple times.

https://docs.hubitat.com/index.php?title=How_to_Build_a_Solid_Z-Wave_Mesh

2 Likes

It actually is a big deal. Z-wave devices don't just stop working for no reason, but if they do, excluding/including shouldn't be the go to procedure. Identifying why devices don't work is the long term solution. Maybe a device went bad, maybe one or more devices are at the edge of the network, maybe the devices overwhelmed the radio. These issues, unfortunately cannot be resolved with excluding and re-including the devices.

As for those that you can no longer add, that's a good indication that they may be at the edge of your mesh and cannot establish a good connection to the hub.

3 Likes

Look for Zwave ghosts and remove them. Shut down hub. Power off hub at wall, wait a minute, then plug back in.

2 Likes

Thanks - as a test I am re-building my Smartthings network and the devices I was having problems with are by and large working on Smartthings (one isn't but I'll get to that). All of these devices are in-wall and within 20 ft of the hub so I don't think the distance is the issue.

How do I look for z-wave ghosts?

Go to Settings / Zwave details. Look for devices with no in or out clusters. Those are your ghosts. To get rid of them, click Refresh ( may take several times) until you see Delete, or Remove. I forget which.

1 Like

I was surprised as I went through my meshed network journey that devices even a few feet from the hub might still rely on repeaters. I also came fro ST and I quickly learned that my ZW experience on one did not match the other. Niether was better, they were just different. I would suggest a brief pause in your migration to focus on the mesh for a bit. It's also possible that a device acting as a repeater has failed... that's always a pain.

2 Likes

Z-Wave routing seems to be one of the more preeminent magical dark arts... forget all you know about space/time and abandon all hope... :mage::exploding_head: :crazy_face:

1 Like

I also just migrated from ST about a month ago. Like you, I found that my Z-wave experience on one hub was different on the other. A few days after I migrated my z-wave network fell apart. It's better now that I've added 4 new devices, the mesh is much stronger and everything works as it should. I'll look to add more devices as I go, more wired switches and outlets.

Good Luck. Even with things at 50% on Hubitat lights and things still worked better than on ST.

2 Likes

Download the Hubitat app