[WITHDRAWN - Use the new Broadlink integration by @tomw] NATIVE Broadlink RM/RM Pro/RM Mini/SP driver

LAN overload may be the issue, but I'm not sure. The five Mini3s are selected with an input statement, and the SendStoredCode device command is the same as sending a saved IR code with RM as defined in the OP's documentation.

Should it be necessary the globalIrBlasters.SendStoredCode(irCode) command could easily be changed to something like:

pauseExecution(100)     //or whatever number of milliseconds works

Perhaps a Hubitat expert knows the answer? tagging @bravenel @mike.maxwell

Repeating my original issue as a courtesy

Anyone know why the codes for the apps and drivers have been removed? I need the HVAC files but everything now gone

It's in this thread. The dev removed them

Post 289

A ha. Awesome thank you. Got em

1 Like

Big caveat for anyone using Broadlink devices. The device is also offline in Hubitat.

1 Like

Not entirely. In hubitat you do not need to re-learn your codes, provided you either learned them in the app, or you syncronized your device codes to the app.

If you taught your codes using the device page rather than the app, and did not sync them to the app yet, do it now. Then simply delete the device that has the incorrect SSID details in the broadlink app. Don't remove the broadlink app itself, or your codes will all disappear. Once the device has been reset using IHC, you simply add it back in the Hubitat Broadlink app. All your codes will have remained and work once again in hubitat. Don't even have to teach them in IHC, unless you use that app separately.

You will of course need to repair any automations created using your broadlink device, as it's essentially a new device.

I have all my codes in the app, so that's handled.

What occurred: My wifi system began acting really strange, with phones and tablets failing to connect. Traced it to the router DHCP function. Eventually I found that shutting off 5Ghz band stopped the issue. TP-Link support suggested changing the password. For some unknown reason that worked, but then I hit the RM mini issue.

I have five RM Mini3s, one for each room with a Fujitsu mini-split head unit. A personal app used with the living room unit, properly turns the TV, Audio system, and cable box on and off. Currently everything is working with the router's 2.4 band. I have absolutely no desire to re-pair the Minis to the IHC app, reset them in the Broadlink app, then change the settings of my personal mini-split user app. Doing it the first time was a nightmare.

My plan: purchase a new router. Still undecided on brand, perhaps Orbi mesh. Use the same SSID and password currently in use with current router, hopefully putting this mess behind me.

will your router take 3rd party firmware? Like merlin or ddwrt? Might save you from buying a new router and open up a whole bunch of new features

No sure.

However I'm now running an Orbi with two satellites, and for the first time have wifi in my garage. Still can't get a zigbee signal into this cement and rebar Faraday cage fortress.

Do you have an Xbee? The signal is very strong, and it's not hard to setup. About 30-35, for xbee & usb adapter

I was wondering if you'd picked it up. Sounds like it's working out OK :slight_smile:

Did anyone ever find a resolution to this problem?

Never mind I found the below which works very well and is so simple to get up and running on a raspi.

I've managed to set up IR code as well as RF codes with the app however I am encountering a bit of a conflict in my settings.

So far I've set up a RF code for my garage door to open/close and an IR code to turn on/off my fan.

I had initially set up the code repeat setting to zero and the fan was working well. The RF for the gate however was not. I then set up the Code repeats = 1, the RF for my garage door is working fine however the IR for my fan now turns on and immediately off since the signal is sent twice.

Is it possible to set the code repeat only for specific codes or does anyone have any idea how I'd be able to make the two work together?

Thank you kindly

Try editing the Code Data that needs repeat 1 as follows:

If the initial code is 'abc......def' change it to 'abc......defabc......def' (example only Code Data is much longer)

save it.

set repeat to 0

try it

I had tried it previously by getting the idea from one of your previous post #365. Unfortunately it does not work. I think my garage remote is the source of the issue as it seems to need 2 distinct requests to be received in order to open. If I click test Stored code once it doesn't open the door however if I click on it twice rapidly it works

If you are using RM or a groovy app to issue the command, try setting repeats: 0, then issue the command 2 times.

That is what the app code does when repeats > 0

Hopefully the timing is not too long for it to function.

For my Cable box I had to edit the learned command then cut it in half where it repeated to make it work. I got lucky, I was at my wits end with that device. So maybe eyeball the command code, if it duplicates attempt to cut it then give it a try if issuing it twice does not work.

Thank you so much you just saved me a lot of head scratching. Sending the code twice with RM worked great!

1 Like

I have found 2 small bugs.

SPMini2 not showing eventStatus: On or OFF, so can't make rules with it.

You need to add these 2 lines:
Drivers Code/Broadlink line 247: sendEvent(name: "switch", value: "on")

Drivers Code/Broadlink line 252: sendEvent(name: "switch", value: "off")

Also A1 sensor not updating temperature:
Drivers Code/Broadlink line 343: You need to change hasTemp= false > true

I don't know much about coding, but it works now. :smiley:

Thank you for all your hard work. @cybrmage


Is this still the best project for Broadlink IR devices on Hubitat even though it's dead or has something replaced it?