Why would hub stop controlling switch?

I am running 2.3.3.125 on a C7 hub. I have an Inovelli red dimmer that is connected to my front hall lights via a line, load, neutral and ground. Physically pushing the switch up or down (1 push or 1 hold) turns the light on and off.

However, even if I go into the device and push the off button nothing happens. As you will see from the below screen shot I pushed the Off button (which is why it is gray) but as you can see from the last item in the list to the right it is still on. I have enable debugging login turned on, but when I push either the On or Off button no log is created.

I tried the Refresh button, and that appeared in the logs, but when I tried to Of switch again, it still did nothing and no log was generated.

Here is the Z-Wave table for that switch:

Here is the events page. However, I pushed the Off button again at 12:41:40 (I was watching the clock as I pushed it) and no event was generated. There are some 1 Held's being registered as events. That is because I created a new button rule and ran it from inside the rule. However, even though the 1 held event obviously occurred, the light did not turn off.

Should I try to Z-Wave repair button or air gap it or what do you suggest?

I’d try air gapping it in the short term, but if it continues dropping off you may need to add a repeater or 2 to allow it to find a solid path back to the hub.

2 Likes

Air gapping fixed it.

Since 100% of my switches are Inovellis that brings me to another question: Do alll brands need to be air gapped sooner or later, or at least less frequently then Inovellis?

When a mesh device stops working as expected, there are a few things that can cause the problem:

  1. Faulty device (hardware)
  2. Faulty device (software)
  3. Weak Link
  4. Bad routing

Troubleshooting the problem must focus on identifying the root cause. The only way to do so, is by using the process of elimination. I usually start by looking at things that can be corrected (bad routing, weak link, faulty device firmware) and leave the device malfunction last:

Troubleshooting

  1. Bad routing >> running individual device repair may solve the problem, also making sure that the nodes the device uses to communicate with the hub are all working (node 5D & 2A in your example):

image

  1. Weak Link >> if the hub had to be moved closer to the device when the device was initially paired, chances are that once the hub was moved in its permanent location, the device will stop working. This usually is reflected on the Z-Wave Details table, which doesn't seem to be your case.

  2. Faulty device (software) >> It could happen that the firmware on the device occurred an issue, power cycling the device may correct the problem. If the device starts working, then checking for firmware updates with the manufacturer may resolve future problems.

  3. Faulty device (hardware) >> It could happen that the hardware on the device is going bad. Power cycling the device may correct the problem, however if the issue returns, then replacing the device may be the only way to eliminate the problem.

NOTE one device that stops working as expected while other devices in the mesh are working, is never the fault of your (controller) hub. In rare cases a recent platform update may have changed the driver that is being used. To ensure the driver isn't the problem, check the Release Notes to see if the specific driver has been updated.

3 Likes

I am 80% Inovelli here and none of my devices need to be air gapped. Check items #4 & #5 in the troubleshooting post above. You may have outdated firmware or a bad device, especially if this continues to happen. Also know that mesh devices that stop working could cause latency or even total mesh freezing for both Z-Wave and Zigbee...

1 Like

The only time I had to air gap my Inovelli’s was when I was first building out my mesh and the signal was at the very fringe.

3 Likes

I just had a very weird issue last night during a power "glitch" - a bathroom light stayed on - but was registering "off" in HE. Turning it "on" in HE did nothing because the switch was already on and off did not work either :man_shrugging:. Trying to turn it off at the switch did nothing because it thought it was off.. I managed to get it working by methodically toggling the switch on and off a few times. Seems like the physical connection got out of sync with the switches "logical connection".. this was on an old Zooz V2 switch.

For switches set to smart bulb mode this can be a pain so always "force on" after powerloss.

1 Like

5D is an Inovelli black switch that is about as far away from the hub as is possible. Why the front hall switch is going through that I don't know. I've tried doing a "repair" of the front hall switch a while back to see if it would find a better route, but that didn't change the route at all. As you see, 5D takes multiple hops and is only at 9.6.

2A is in the same metal gang box as 5D, but although it also takes multiple hops it is connecting at 100. (BTW, I live in a condo and I am not allowed to swap out the metal boxes for plastic ones).

As 5D is only connecting at 9.6 it seems a bit strange to me that the Front Hall switch, 56, is connecting at 100. I guess that is just part of the mysteries of Z-Wave.

I know there is nothing we can do about it, but my #1 wish for Z-Wave would be that we could designate a route for devices.

I bought a couple of Aeotec 7 range extenders and put 1 of them between these devices and the hub and the other by other devices that take multiple hops and run slowly, but even though its been months, virtually none of my devices have ever switched over to using them.

What do you think about doing a Z-Wave repair of the whole mesh?

And, BTW, I've found that I, all too often, have to air gap some of my Inovellis. As to firmware updates, I used to do this religiously until I had some real problems getting the firmware updates to complete. I will look to see if I have done the firmware update to this and one other switch that has always given me problems and I've had to air gap multiple times. I think I might have gotten a bad batch as I had to return a couple of them that were dead in my box of 10. (And BTW, I had professional electricians install the switches, not myself).

You cannot see what the radio sees, so you would be less successful at routing nodes more efficiently than the radio itself, unless you use sniffing tools to identify best routes. 99.9% of users want convenience not a second job to maintain their mesh networks, although for those who want to be in full control, I agree is less ideal.

1 Like

You can go around metal boxes by adding repeaters to boost the strength of your mesh. Constant power cycling is at best a band-aid that will have long term negative effects on your overall experience.

If you add mains powered devices and/or move the hub around, you could benefit from running a full mesh repair. It would also be helpful to identify the weakest links in your mesh, giving you ideas where you might need more repeaters (or what devices to replace) if repair fails.

As I mentioned, I did buy repeaters after I saw some mesh weak points but that never did anything.

I did move my hub a few months ago to a much better spot and moved the Aeotec repeaters (which are both 700 series) to face directly at 2 of my 2 gang boxes that were the most problematic. None of those 4 switches or any of the other switches nearby have ever switched to the Aeotecs.

I did try to do a firmware upgrade on my Front Hall switch just now.

I went from 1.48 to 1.61 for 0. That took about 43 minutes using the Device Firmware Updater. However, when I tried to go from 1,41 to 1.45 for 1, it went quickly to 66% and then hung there. (I waited over 1/2 hour for it to move beyond 66%). I then aborted and tried it again, but it either said it wasn't receiving the update or one time hung at 2% (I waited over 15 min this time for it to move past 2% aborting the update). I then went into the device itself and tried to update 1 by using the Z-Wave Firmware Updater Drive but that didn't work either - it said I never got beyond 1%.

BTW, I can't use a Z-Wave stick as I don't have a PC only a Mac. So for now at least, I cannot update the firmware on the Front Hall switch for 1 to 145. I used to be able to update the firmware, and had done so on previous occasions, but for some reason I'm having this problem so much that I've only updated a very few of the switches to 1.61/1.45.

Try moving the repeater to about 2/3 of the distance to the hub from the switch; seems to work better for me.

2 Likes

This topic has been marked solved by the community and subsequently closed. For further discussion on this topic, feel free to create a new thread under a different category to continue the conversation.

If you are logged in, click [HERE] to get started.

Download the Hubitat app