Why isn't my hub discoverable?

Brand new device. Plugged in with green light. Tried discovering through my mobile browser. Nothing found. Tried discovering through browser on wired computer. Nothing found. App discovers the hub, but after entering the hub name and zip code and checking the box, clicking "Claim", nothing happens. It's like the button isn't there.



I have tried Chrome browser on my phone and on my desktop computer as well as the app. It's not finding anything with any method.

Could try:

[Javascript] Hub Finder

1 Like

Do you have any vlan's? Do you have access to the DHCP table in your router to see if it was issued an address? (if it doesn't have a name just look for the last 4 digits of the mac address on the label on the bottom of Hubitat). Have you tried a different cable? Are your pc and hubitat on the same network? (not just physically but lets say your pc is 192.168.1.x is the hub on 192.168.1.x as well?

1 Like

If you look in your router's DHCP table can you find the hub? The MAC address for your Hubitat device should start with 34:E1 . Your specific MAC will be on the hub.

If you can find the IP address for the hub in your router (usually 192.xxx.xxx.xx), you can type it right into the browser address bar, and it should go right to the hub.


And to @neonturbo..

This is all new to me. I'm not sure how to answer most of your questions. I'm definitely a novice when it comes to internet connections. I have no idea what DHCP tables or VLANs are

I believe these screenshots might answer some of the questions.

For the ethernet cord, I have only tried the included ethernet cord. I have reset my router and the hubitat. Both website and app are currently saying they found a hub at, but obviously that leads nowhere. Clicking Connect to Hub on website tries to open that IP address. App doesn't even let me click claim (nor does it show me to click on the TOS link), even after entering make and zip code of hub.

Light on hubitat is green.

Can't send links so here is the text from performing IPconfig on my ethernet-connected desktop.

Ethernet adapter Ethernet 2
Connection-specific DNS Suffix:lan
Link-local IPv6 Address: fe80::152b:b298: abae:1823%9
IPv4 Address:
Subnet :
Default Gateway: 192.168.40

For Wireless LAN adapter Local Area Connection (11 and 12), Wireless LAN adapter Wi-Fi (1 and 2), and Ethernet adapter Ethernet 3, they all show Media disconnected.

My desktop is plugged into the top port on my router, Lutron hub into second, Hubitat in third.

Mac address of hubitat is 34E1D1814C79. Router is a Adtran model 834-5 Wi-Fi 5 Gigabit Router supplied by my ISP.

Hope this info is helpful.

1:> Press the reset button on the bottom of the hub for 7 seconds with a paper clip or toothpick.

2:> Download Advanced Port scanner and run it https://www.advanced-port-scanner.com/

3:> Use your desktop to connect to the ip address if found.

Now for DHCP reserving. If you are using windows, click start, type CMD and hit enter. Type ipconfig and click enter. Note your gateway ip.

Using a browser go to that ip address and log into your router. Under the network settings you will find DHCP options. You want to pick and IP and match it to the MAC address on the bottom of the hub. This will insure that it always has the same address.

Thanks for the response. Both that software and IPconfig give Typing that in my browser gives me an error message saying the address refused to connect.

Hmm... Were you able to find the hubitat with port scanner?

ipconfig would only give you your PC’s information and the gateway. If you try the HTML/Javascript option I posted above I’d suggest using:

base = 192.168.40.
iterations = 253


I was not able to find it unless it would be called something I wouldn't recognize.

@support_team this user still is having trouble, could you assist?


Does going to http://hubitat.local/ in the browser while on the same network bring up anything?
Can you PM me the MAC address of the hub (it's printed on the bottom of the hub itself)? I can check if it is connected to the cloud.

1 Like

Tried going to that address, site can't be reached. I will pm mac address.

Site will not allow me to pm you. Also won't let me send messages or submit posts with a link in the body. Another way to send to you? I did post it in a previous response though. Should I have not done that?

Because you are a (relatively) new user, you don't have full posting permissions yet. I don't know if gopher can fix that. Maybe he could PM you first and you reply? @gopher.ny

1 Like

He was able to message me to start a conversation. Thank you!