Why do groups suck?

For whatever reason, groups appear to suck for me. I frequently have issues with rules that involve groups.

Sometimes they won't finish processing, sometimes only a few members will execute, sometimes they work flawlessly.

Anyone else see random and unreproducible behavior with groups?

I have found groups and scenes as a combination to be difficult to get right straight away. I think that's the most diplomatic way I can think to put it... :slight_smile:

But for your case, it may be useful to list out some of your setup, i.e. what bulbs are you using, kinds of rules or apps you are trying to use, etc. It may not necessarily be the groups, could be the devices. It's hard to know for sure.


Also, are you using scenes? Forgot to ask, I have had some issues with them, more so when I mistakenly turned on the "don't respond to off" setting.

No scenes but a good mix of groups. Some have a bunch of GE z-wave switches, other just have a few zigbee bulbs/devices. Nothing really in common except for groups. If I remove them and set the rules for the devices themselves the success rate goes up drastically. The downside is it makes changes or new rules a total PIA to manually add each device.

I started trying repeating actions with a delay to help catch the devices that may not execute the first time. So far it's been helping, but I feel it's just masking the underlying issue.

Exclude the Roomba.

No Roomba here. I do have the Shark ION integration setup but that is not part of any groups

It's going to be a struggle with combined technologies in a single group. If you have Zigbee group messaging enabled, try turning that off. Try also disabling on/off optimization.


I'm not sure I'm following why this should be done for a mixed group. How does it hurt?

Agreed - 100%.

Already have that set to off. Maybe the mix of Zigbee and Z-Wave in the same group is adding to my issues. Especially for my "Everything" group that I turn off with my Good Night routine

Two different thought processes in one sentence! :crazy_face:
Because I've no idea what the OP had for the Zigbee setup, safe starting point is with it off. Not all devices support Zigbee group messaging in the same way. I have had major problems controlling a group of Zigbee devices from OSRAM and Sengled at once. Turned off group messaging and it started working just fine.


Yeah, you might try grouping all the Z-Wave together, and all the Zigbee in another group. Then turn off the two groups in your goodnight rule. That'll maybe will show you where further issues are too.

You can try turning on Zigbee Group Messaging if all the bulbs in the group are directly joined to HE (that's number one) and they are all the same make (not saying it can't work if their not, but success rate is higher in my experience). I've not found the on/off optimization to work well with my setup. YMMV of course.


I have suffered the same problem in the past.

I have found it affects the most when the group (or the command) is related to closely placed and multiple (many) devices.

My solution, far from elegant, is to repeat the order twice (i.e. dim level or color temperature change). It is quite effective.

Guessing on what is going on, it may be the case that the commands overlap when trying to reach different devices through different net paths, with some devices not β€œhearing” a command since they are receiving another one?

1 Like

That's exactly what I've resorted to. Send the same exact command twice, with a 20-30 second delay

1 Like

If you are desperate and really wanted to go crazy though you could create 2 groups per desired "group".

  • one for "on" with "Use group device to indicate if any members are off" selected.
  • one for "off" with "Use group device to indicate if any members are on" selected.

In your rules you could then test the "on" group to make sure all lights are on and if not repeat the on command. Same with off..

1 Like