Why do C8 network connections lock up when the ethernet hard-wire is disconnected?

I've searched through the community and while there are similarly related topics, I couldn't find the answer to this question. Please point me in the right direction if I missed it.

On the C8 Network page there is a warning to shutdown the ethernet before unplugging the network cable.

It seems that if the network cable is broken by any means, either the cable is unplugged, or if the modem/router that the hub is plugged into directly is powered down and back on, Hubitat will not restore the network connection until the C8 hub is powered off and back on.

The warning on the network page appears to indicate that this is a known issue, or a hardware issue that can not be corrected with a firmware update.

I have two C8s running firmware 2.3.6.146. It is connected to my network through both wifi and internet with DHCP reserved IPs for both network connections. One is connected directly to my modem/router, and the second is connected through a separate switch.

I have rule machine rules which will power off my cable-modem/router through an auto-on z-wave switch if the internet connection is lost.

Whenever the cable modem/router is power cycled, the C8 hub will not reconnect to either network as described above. This is consistent and repeatable through two different cable modem routers (Xfinity XFi, and Arris G54). It does the same when connected through my switch (TrendNet TEG-3102WS), and the switch is power cycled. In each case, the Hub light remains green indicating a good network connection. It is unable to be accessed directly or through remote access, and the hub mesh is broken to the disconnected hub. However, if the hub is connected to a switch, and the modem/router is power cycled (switch remains powered), then the Hub network will reconnect just fine to both wifi/ethernet.

My C5 and C7 hubs don't appear to have the same issue.

I use both wifi and hardwire connections as a backup network connection for remote access in case one or the other goes down.

Is this a known problem that will be corrected in a future update? I read somewhere about jumbo frames locking up the network connection, but I am not sure if that is the source of the issue.

If this is known - is there any work-around or recommended network setting to help mitigate?

Thank you!

1 Like

Feels like one for @gopher.ny to comment on, unless @bobbyD has any insights? (I certainly don't :slight_smile: ), but I know there has been plenty of work in this space and many other aspects of platform stability, so if it isn't being worked on, there certainly does seem to be an appetite for this at the moment.

Interesting. I have not had that issue. I even tested it now and unplugged the network connection to my c8 for a min and plugged it back in. I also shut down and disconnected power for 2 mins and brought it backup without the firewall connected. It took a few moments to poll for it's reservation but it works fine....

1 Like

I did forget to add I have restarted my router and/or had it have issues, but the C-8 has always stayed on the network when I expected it to.

2 Likes

Had a modem go belly up the other day. In the process of trouble shooting I powered my router down several times. Both my C5 and C8 connected right back up with no issues. I didn't check how long it took for the reservation.

3 Likes

The hub doesn't have a network failover functionality. It can only connect to one network (hardwired or wireless) and can't switch between them without restarting the hub. The hub should be able to reconnect to the same network if the router is restarted or the Ethernet cable is replaced.

It should be able to reconnect to the same network. Be sure to update your hub to the latest platform version, as 2.3.6 update has network enhancements that may help the hub reconnect.

Also, it is not a good practice to have Wi-Fi enabled, if the hub is hardwired, as the hub may run into problems trying to connect to a Wi-Fi network that might not be properly set-up, even though the Ethernet connection is active (this will result in the hub's led flashing red).

3 Likes

Because neither C5 or C7 offers built-in wireless connectivity.

3 Likes

Thanks Bobby, and everyone!

When I look at the network settings, it shows both networks connected, and I can reach the hub web interface through either IP address.

I am running the latest 2.3.6.146 firmware.

I am also running a 2.5Ghz wired network with a 10 Ghz connection from the modem to two stacked TrendNet 2.5Ghz switches (10 Ghz direction connection between them). The remote switch that the 2nd hub is connected to is a 1 Ghz switch connected through the TrendNet.

Hubitat always connects with an auto-negotiated 100M FDX connection as expected. Not sure if the faster network may be causing the issue. When connected directly to the modem/router, those are 1Ghz connections. The Xfinity X8 has 3x 1Ghz ports and 1x 2.5Ghz port to the switch. The new Arris we replaced it with has 3x 1Ghz ports and 1x 10Ghz port to the switch.

What is more confusing is that this is repeatable in every case, and it doesn't matter what switch we plug it into, either the switch, or the modem directly.

You have each hub simultaneously connected to both Ethernet and WiFi?

Yes - With the ethernet connection made, then adding the wifi connection, both come up connected.

Could this be the explanation for your issue then?

Why are you connecting the hubs with both Ethernet and WiFi?

Have you tried connecting with just Ethernet?

4 Likes

As mentioned above, that is not a good practice. As you may learn in your Hubitat Elevation journey, at Hubitat we strongly believe that one's imagination is the only limit, and sometimes, users may find that just because you can, doesn't mean you should. Generally speaking, we don't put up guardrails to prevent accidents, but rather warn folks that bad things may happen. Rarely, when too many users fall into their own trap we may consider closing the gap, but that is rather the exception, not the rule :wink:

7 Likes

Will try disconnecting the wifi and just go with the ethernet, then see if we have the same issue. Previously we were having a lot of issues with the network stability which is why we replaced the modem/router. That and I didn't like going through the Xfinity interface for router management, DHCP reservations were a mess.

We kept dropping connections, so I connected the wifi as a backup so most likely at least one of them would restore. Both network connections restore fine when the C8 is restarted, but either hub will lock up when the network cable is disconnected for any reason. Will let you know what happens.

Any explanation to the warning on the network interface page (shut ethernet down before disconnecting cable)?

Thanks!

It's (mainly) for users attempting to switch between the Ethernet and Wi-Fi.

2 Likes

Tried disconnecting the ethernet cable after disabling the wifi. Hub flashed red/green as soon as cable disconnected, and the network did not restore when the cable was reconnected. The switch did not register an active connection on the port (it is a managed switch). We tried rebooting the switch with no success throughout all tests the hub remained flashing red/green. The network connection finally restored after we rebooted the hub. Review of the logs indicated the hub was still active after we disconnected the network cable, however we just aren't able to access.

To set up the test we disabled the wifi in the settings so that only ethernet showed a connection. Then we rebooted the hub, upon startup the hub reconnected to the reserved hardwire IP address.

I have this very same issue. Not always, but maybe 3-4 times in past 6 months, when my power goes out and router goes down (hub remains powered thru APC), or if I pull the network cable, it locks up.

1 Like