Why aren’t my ikea outlets in the refresh list?

I have three ikea outlets. I have a simple automation rule that uses two of them to turn Christmas lights on and off each day.

I am finding that one of the outlets doesn’t come on because Hubitat thinks it is already on.

So I went to put a rule in place to refresh the outlets. But when I went to select the outlets as the devices for the refresh action they were not in the list. I thought that was strange since they have a refresh button on the device page.

Is the rule engine not able to interact with ikea outlets?

If you select run custom action and select the actuator capability it should list all commands the device has for use in rules.

1 Like

I don't want to distract you from your stated goal, but the Ikea outlets should automatically send state changes back to the hub. I've seen people report similar problems here, and hitting "Configure" on the device page usually fixes the problem. If you aren't using the "Ikea TRADFRI Control Outlet" driver, switch to that first, then save those changes, and then hit "Configure" (otherwise just try "Configure").

The above is certainly a workaround you can use if this still doesn't work, but I just wanted to point out that you shouldn't need to do it. :slight_smile: Also, I'm not sure about the default behavior in Simple Automation Rules (it may check to see if the device is already in the expected state? I didn't know that before), but I know Rule Machine won't, so you could consider putting this automation there instead. If that still doesn't work, then you have some other problem that any of this might not actually fix.


Or maybe a signal strength issue?

Go to (insert your hub IP)hub/zigbee/getChildAndRouteInfo and see if this shows up there. (it may or may not).

If it does, what is the LQI, Incost and Outcost look like?

Thank you for suggesting the "Configure" command. I think that may have been the problem.
I will wait until tonight to see if the automation turns on the outlet this time.

Once I hit the configure button, I noticed that manually turning the outlet on and off instantly updated the status on the device page. It wasn't doing that before. I would have to turn the outlet on, then hit refresh to see that it was on. But once I hit configure, this status change is instant.


Exact same behaviour here. I've only needed to hit configure after initial install. Never again. I've got about 20. =)

What driver is being selected when these initially are included?

If the correct driver is being selected during inclusion there shouldn't be any need to click configure...

I installed them a few weeks ago, but I am pretty sure that the Ikea driver was selected automatically. I don't recall having to search for the right driver.

driver: Ikea TRADFRI Control Outlet

I now wonder if this was the reason that my other rule to reboot my router once a week didn't appear to be working at first. Now, I know ... hit the configure button for good measure. :slight_smile:

I've seen these be a bit flaky during pairing.

There's a timing issue where they seem to go deaf to incoming commands for 10 - 15 seconds which impacts any configuration being sent / received.

I've paired about 40 of these now over the past year, it's not a repeatable problem as far as I've tried, but it happened a couple of times during the first 10 or so that I paired, so after that I made a point to hit configure after a couple of minutes just to make sure.

Well the configure seemed to work. I am not home to physically see that the lights are on but I VPNd in and the device says the lights are on and the state stayed on after doing a refresh. So I am pretty confident that it worked.

Thanks to all who provided input.