When adding Hubitat to Google home, I get a DNS error

My problem is that I can not integrate Habitat to Google home.
I get DNS error:

I open Google home/ add device/works with Google/ search habitat/ choose habitat.

Get error.

My Habitat is new. I got it three weeks ago, before the version update.
When I tried to add the habitat to Google home, I saw an icon with the green color. Adding the habitat to Google home worked, but I only had the Ikea bulb, which did not work.
After upgrading the habitat version, I now the a different Icon in Google home integration. It has purple color now, and errors.

What other info to provide?

Are you using an unusual setup, like a reverse proxy with a custom domain name or some kind of third-party remote tunnel? What if you access the hub directly (while on your own network) by its IP address to rule out that as a problem?

The URL in your screenshot does not appear to be anything from Hubitat itself, hence my guess you have some setup like the above.

1 Like

I just checked Google Home and I see that "Habitat" and "Habitat Homelink" are both options to integrate with Google Home, but neither one has anything to do with Hubitat.

I have no idea what either of those Habitat things are. But Hubitat cannot be integrated into Google Home from within Google Home or Google Assistant itself; you need to instead use either the native HE Google Home integration or the community Google Home app.


The guess above is probably a better one than mine. :smiley:

1 Like

Ha, mark your calendars boy & girls - this day in history won't ever happen again :rofl: