What would cause time based triggers to not fire half the time?

I have a rule with a simple trigger. "at 9:00pm"

It lowers the 3 blinds in the bedroom. Pretty simple statement.

It has a habit of not triggering the blinds and half the days I have to lower them manually. Today they didn't trigger but if I run the rule they go down just fine.

I would look at the logs and device events. If no device events enable logs.

You can also look at the devices being controlled and see if there are any scheduled events.

Are you trying to do this in Basic Rules or in something like Rule Machine?

I try to do everything in Basic Rules if possible. I have lots of things that are controlled based on time and they all work properly.

If you trigger the blinds manually using the device properties, do they respond promptly? If the rule triggers sometimes, but not others, the issue is more likely to be with device connections than it is the rule.

Are the blinds Zigbee or Z-wave or something else like Lutron? Do you have a strong mesh so that all the blinds get reliable signals. Remember that blinds do not operate instantly like a light switch, so you need a strong signal. It might help to add some repeaters if you have Zigbee or Z-wave devices.

This is in Rule Machine:

Select Trigger Events (ANY will trigger)

When time is 9:00 PM


IF (Variable DONOTDISTURB(false) = false(T) [TRUE]) THEN
IF (NOT Mode is Away(T) [TRUE]) THEN
IF (Bedroom Window Sensor open(T) [TRUE]) THEN
Position Shades: Bedroom Shade to 40
Lower Shades: Bedroom Shade
Lower Shades: Bedroom Side Window Shade, Bedroom Door Shade

I have the Hubitat in a central location in a 2-bedroom condo so the Z-Wave Bali blinds are just 1 wall away about 30ft or less. Plus there are other Z-Wave devices in the rooms so those are supposed to get the signal around to everything.

If I run the rule from Hubitat's interface in the App screen they trigger just fine. And they seem to all either lower or none of them do, so that tells me its the rule not being fired vs a blind not getting the signal since there are 3 seperate blinds in that room. And when they don't lower at night its all 3 of them. Sometimes they go down sometimes they don't. I'll work on watching the logs and events each day to see what happens there.

I was wondering if I should change the trigger event to be a time range so it would get activated multiple times and eventually should work like a trigger set to Between 9pm and 9:10pm. Would something like that work?

I get that triggers are singular events. And I couldn't see a way to make a trigger that would fire between a time range since that would mean multiple events. But putting the time range in the conditional of the action doesn't do what I'm thinking. Is there a single statement or type of trigger that can be setup to be repeated. Other than just hacking it making a bunch of Apps each a minute apart for like 10 minutes that all call the same routine, like flipping a virtual switch that triggers the rule? Sounds like an inelegant solution, but I'm getting tired of testing and fudging with getting the blinds working.

Please look at the App Status page (gear icon) at the bottom of the page. There is a section called Scheduled Jobs. It should have a scheduled job there for 9:00 pm. If not, let me know.

You can turn on Event, Trigger and Action logging for this rule, and see if the rule is actually being triggered at 9:00 PM. If it is triggered, see what the logs say as to the actions it performs.

Triggering multiple times is not the solution to this issue. First have to see what's actually happening, and go from there.

Okay, I'll start tracking it at 9pm and keep an eye on the logs. I'm out of town for a few days so it'll be into next week before I have some more info.

Allthough you might have multiple Z-wave devices in a room, remember that only mains powered devices will act as repeaters/range extenders. Battery powered sensors do not repeat.

I have a Schlage Z-wave lock that is only 35 ft from my hub. It would not work consistently until I added a Z-wave repeater close to the lock.

If the hub is trying to send signals to all three blinds at the same time, there might be some signal interference. It should not happen, but if the signal strength is weak, it might. One thing you might try is to run some tests using only one set of blinds. If that works consistently, then you could set the blinds so that they close a minute apart.

I'll look into a zwave repeater. One of the blinds is wired, the others are on battery. There are also multiple zwave wired wall switches inbetween the hub and the blind in that room.

1 Like

Hi @ILauder did you resolve this? I have a similar situation.

I did put in a couple plug in repeaters and it seems to work more consistently now with those blinds in the back rooms.

1 Like