What to do with Hue Bridge Integration when "current Hue username is invalid."

This suddenly happened to me when I changed the channel on my #1 Philips Hue Bridge. I have four of them, each integrated with Hubitat through a separate instance of the Hue Bridge Integration.

Now, with the #1 instance, I'm getting this error message: "The current Hue username is invalid. Please press the button on your Hue Bridge to relink." Pressing the button does nothing.

All devices that were previously controlled by Hubitat vis this bridge are now unresponsive, except for in the Hue App itself.

How can I save this situation without having to reinstall all the devices and all the automations they are involved in which this Hue bridge controls in Hubitat?

In the Hue Bridge Integration app, go to Options, then hit Clear Bridge Link, and then hit Done. You should again see the message you describe, and hitting the button should re-link the Bridge. I just tested this and it worked for me. (I have nothing important using the built-in Hue Bridge integration, so I had nothing to lose. :slight_smile: ) However, there was some oddity in the UI--the message you described appeared twice for me, but the second time it just worked when I hit Next or Done or whatever appeared on that screen, which I can no longer remember...

An alternative: you could restore a hub backup from a time when you know this worked (one is done by default around 2 AM every day if you didn't change any settings or make one soon before that). This assumes nothing crucial changed on your Hue Bridge, like a reset that would have erased the allowlist of usernames, for example.

Maybe I'm looking in the wrong place but I don't see an option for "Clear Bridge Link." I assume you meant the particular instance of the Hue Bridge Integration App that is causing the problem, yes? I have four instances in this case, but only #1 is giving me the problem.

EDIT: I've tried restoring from a backup from two days ago before the problem started. Strangely, I'm having the identical problem with the Hue Bridge Integration.

Yes, this should be inside the "Options" page you can get to from the main page of the Hue Bridge Integration child app (for that particular instance; all assuming you're using the built-in app and not a community offering). If the problem persists even after restoring a Hubitat backup, it's possible something changed on your Hue Bridge, but if it's otherwise working as expected, restoring the authentication like this should work.

I can see where the "options" page is in my other instances of the Bridge, but in the one that is not working, it's not letting me go there. When I tap/click on that instance, this is what I'm getting:

The only thing I changed with my Hue bridge was its Zigbee channel, But I did that with my #2 Hue bridge and I had no problem.

The only think I can think if that I did differently was that, after changing the channel on my Hue Bridge #1, I went into CoCoHue App (instance #1) and some kind of reset thing. I went to Advanced options and I think I tapped on "Edit Bridge IP, re-authorize, or re-discover" because I thought the problem was there... until I remembered that the CoCoHue App only has the scenes while the Hue Bridge integration has the lights themselves.

Interesting. The button should definitely be at the bottom of the window you screenshotted, but since it's built-in app and I haven't seen this problem before, I'm not sure how much troubleshooting I'd be useful for. Maybe try the usual advice like seeing if a different browser helps.

I can say that CoCoHue would not have affected the built-in integration, as they each request a unique username, and to my knowledge (definitely not in CoCoHue), neither will request a deletion of that username from the Bridge. I don't even think anything besides Hue's website (or, of course, a bridge reset) is able to do that on recent firmware anyway.

Restoring to an even older database did not fix the problem. Trying to access Hubitat with two other browsers also did not fix the problem. Even accessing Hubitat through the iOS app doesn't fix the problem. Bottom line is that it does not give me access to the options menu no matter what I do. Frustrating! I assume the only option I have left is to remove this instance of the App and reinstall, which means having to reinstall all the lights and, I assume, possibly all the scenes via CoCoHue?

OK, I deleted the defective Hue Integration App. Couldn't figure out any other way around the problem. It's taken an hour, but I've imported the lights through CoCoHue #1 and put everything back where it is supposed to go. Thanks for the help in any case.

Glad you got something figured out! In case it was not apparent from this, the built-in Hue Bridge integration and CoCoHue are completely separate, so any changes you make to one--including removing, adding, re-adding, etc. the app--will not affect the other. (The most confusing thing is that you may get duplicate devices and have to figure out which is the one you really want; both use different DNI patterns if it comes to that.)

I can't speak to the problem with the built-in app, but glad you were able to find a way around it (albeit one that required some device-swapping work).

Thanks. So remember how I said I could not control the devices properly when I imported them through CoCoHue, so I instead imported them through the official Hue integration and did the scenes only with CoCoHue?

Well now I don't seem to be having that problem, at least not with the devices on bridge #1 which have both the lights and scenes imported only through CoCoHue.

My remaining three bridges have the lights all imported via Hue integration. I'm wondering, if I get rid of those Hue integrations and import the lights through CoCoHue, would they be recognized as the same lights in the same rules and in the same previous groups? Probably not but I thought I'd ask.

Unfortunately, as you guessed, nope. :slight_smile: (Apps reference devices by a Hubitat-database-assigned ID, which will be unique for any newly-added device, and there is currently no way to swap out devices for one another except manually.)

I just had this same issue.. When opening the app for my living room hue hub integration, it wouldn't show a next, or done button (on that invalid usename screen), when hitting the button on the hue hub.

To work around this I used and changed a link from one of my other hue hubs integration that was working, to get to this config screen.


Once on that page, I was able to select the correct hub, and get it to progress when I hit the button on the Hue Hub. I then hit DONE on the config page, went back to the Hue App, it waited a few seconds then told me the hub was linked, and everything worked as normal.

I didn't lose any of my mappings this way.. Thankfully! as I would have had to redo 20+ bulb integrations with automations. etc.

  • Shane

Wow, good thing I documented this. I just had the other HUB have this exact same issue. I wonder if there is a timeout / auto logout time period...

Anyway to clarify... goto (insert hub ip)/installedapp/configure/(insert hue integration app number)/bulbDiscovery

Then click on the hub button above options, go through and do the push button thing, and next / done until you are back to the hubs apps list. Wait a minute or so then go back into the app and it should say its linked up and continue.

To get the app number for the above url, just look at the url it gives you when clicking on the hue app on your own hub.

Hope this helps others!

  • Shane

@NerdShowAndTell thank you for this! This is the second time that I've that this bug issue with the Hue Integration. Last time I had to go through a trial and error process where I added another Integration and set it up for the same Hue hub. Somehow and after a bunch of fiddling I got it reconnect on my original Integration.

Your method is much smoother! I hope that this bug gets fixed soon because we really shouldn't have to use this workaround. Glad to have it though for the next time!


You're welcome! I haven't had to do this in awhile. Not sure what causes it.

Download the Hubitat app