What is the difference between the Google Home app and the Chromecast Integration app?

I noticed in the Built In Apps a "Google Home" app. I have been using the Chromecast Integration (beta) app for some time with mixed results. I have a Google Home Mini speaker for TTS announcements. Is the Google Home app replacing the Chromecast Integration app? I would rather not install Google Home on my phone. I don't use voice recognition for control and don't plan to do so. What is the difference between them?

They are pretty different: Google Home exposes devices from your Hubitat hub to the Google Home app/Google Assistant, so you can do things like voice control: https://docs.hubitat.com/index.php?title=Google_Home. The Chromecast integration gets Google Home speakers and whatnot into Hubitat as media/speech devices, so you can do things like play/pause from Hubitat and (probably the most common usage) do TTS from Hubitat to the speakers ... if it works for you. :smiley: (Beta for almost three years now, but got some love in 2.2.8.)


Unfortunately, that attention in 2.2.8 seems to have caused some problems. TTS is not working consistently. Since the 2.2.8 update, I go to disarm the HSM which is supposed to announce the state, but I don't get the announcement. I can go into the device and initialize it and send a text announcement. Later on, when It should be announcing something . . . nothing.

I will pass on the Google Home app then. Hopefully, the Chromecast Integration will be fixed quickly.

1 Like

I keep reading this rumor that Chromecast Integration was updated (in some way) for 2.2.8 but no mention of it in the release notes. Can anyone provide a little more detail on this?

1 Like

The biggest change I know of, and the only specific one I've seen mentioned, is that additional effort was put forth in trying to keep the connection from dropping (which seems to be a problem many were having and the reason for such community apps as Chromecast Helper). I suspect there were more tweaks given that errors I've seen like yours that you posted in another thread don't look like they could be related, but I don't think anything else has been shared.

I only use the speaker for TTS. I don't use it for any other purpose. I have the microphone turned off as I only want it to do TTS announcements. There should be no other interactions. I did make a rule to check to see if the volume had changed and it would work to set the volume to 80 in the evening when it set to 45 without me wanting to do so. I will try pausing that rule to see if perhaps that is causing this issue.

Okay. at 9:09 a.m. I last had the speaker announce a test message after initializing. It is now 12:25 p.m. and I tried to send a test message and nothing happened. I just went to the device page and initialized it again and sent another test which worked.

Something is broken with the update.

1 Like

Tagging @gopher.ny since he may be interested in your Chromecast issue

1 Like

TTS stopped working for me too after the update.

1 Like

I also was not receiving my TTS messages and only noticed after 2.2.8 updates. I setup a rule machine rule to initialize my Google home devices hourly. This seemed to work for me. As for the hourly time-frame it was just a shot in the dark, but seems to be working. I am hoping to just leave this temporarily until whatever is causing the drop is corrected in a future update. @gopher.ny

1 Like

Would you post the rule for initializing? I created a rule, but I would like to compare and see if I did it correctly.


Do not modify the fields below initialize.

1 Like

Just a +1 in TTS crapping out now. I know it's beta but it did work more consistently.

Google recently made a change to their free translate service (which is what a TON of TTS implementations use). There's pretty strict rate limiting on it now so I was getting a lot of errors when using out of the box solutions especially when trying to cast to multiple chromecasts. That might explain why the HE app is having issues.

In terms of a solution, I don't use the built in app so I couldn't help you. I have a workaround implemented in node-red but it's pretty involved and requires Google API credentials.

Same here after the update. Looking at the device page there is a lot of "backed up" messages showing. No matter times I hit initialize, it won't play anything. -Joel

It appears that the update may have fixed the TTS issue. Either that, or the initialization rule I created in RM-5:

Either way, it seems to be working again. I hope I am not premature in saying so.

Update 7/27/2021: It looks like the new rule is working to keep the Google Home/Nest Mini working properly. I have not had it fail since creating this rule.