Wemo switch and insight smart plug


#21

@jason0x43

I appreciate the response. I am looking at the controller code and it doesn’t have anything for the insight plug. So my question is the where did ya’ll get the original code to port over to Hubitat? Maybe I can reference that to add the missing code?


#22

Probably smartthings forums. That’s the go-to place for code to migrate to Hubitat.


#23

@EdwardN

Yeah that won’t help. I am looking for @jason0x43 code so I can contribute to it also. This is one of the many on my list that I need to get working.


#24

The controller code just needs some minor updates to its addDevices method (around line 419) support additional drivers. More drivers are available here.


#25

I am looking at the code you sent me to compared to your code and I do not see any differences. :frowning:


#26

No, the log I posted was from the install and included me hitting done.


#27

My code is at GitHub - jason0x43/hubitat: Hubitat apps and drivers, while the original code is at GitHub - SmartThingsUle/Wemo.


#28

It’s not a driver issue, it’s just that the current version of my Connect app only handles Switch and Motion devices, not Light Switch or Insight (or any other WeMo devices). Even if a driver is there, the Connect app won’t know about it.


#29

Got it. Those will stay on ST for the time being.


#30

Waiting for my hub to get registered…while waiting…i have quite a few Wemo light bulbs. How do i get them connected to the hub. Any specific drivers?

Been using ST and have decided to make the switch to hubitat…so very much a noob when it comes to adding a device.


#31

I pushed updates to my WeMo app and drivers, with the main change being that Insight and Light switches are now supported.

Note that I haven’t tested this since I don’t have any Insight or Light switches. However, the commands are mostly the same (exactly the same between Switch and Light Switch), so I’m hopeful that things will work reasonably well out of the box.


#32

Works like a charm with the light switches. Thank you so very much!


#33

Cool…will give it a try. Have been using the generic Zigbee driver for the light bulbs…it is pretty iffy as on webcore i need to use an emulated command “Set switch” rather than “Turn Off”…plus a wait 2 secs and another Switch Off…to get it to work 70% of the time.

Will give your driver a try when i get back.


#34

Just tried, the app was not able to discover the light switches :frowning:


#35

Do you have WeMo switches? This app and driver are specific to those, and won’t work with any zigbee or zwave devices.


#36

My bad. Saw light switches and instantly thought it was for the wemo bulbs as well. I have the wemo bulbs and am using the generic zigbee bulb driver. Was hoping to have something more ‘wemo’ as turning off the bulb on webcore i need to send the command twice to get the status to change to ‘off’.


#37

Interesting. I didn’t even know Belkin had made any Zigbee bulbs (and it looks like they don’t anymore). ST’s site makes them sound like reasonably standard zigbee bulbs; I wonder why they’re misbehaving?


#38

Not sure what to do next. It sees the Insight but never creates the device.


#39

Haha. Yea, i think it was only launched in specific countries. The bulbs are misbehaving terribly as it also keeps dropping off the network and needs repairing almost every day!!! I found the DTH over on ST's Github but am not someone who knows code - are you able to do a quick modification for it to be able to port into HE?

I tried just copying and pasting, it sort of works......only thing was it can't switch level, and when turning them on, it defaults to 30% or something....really weird. Would be great, if it's not too difficult, to get it ported to HE properly...

Here's the ST DTH


#40

Did you click 'Done' in the Connect App? Try doing that with the Logs page open in another tab and see what log messages are displayed from the WeMo Connect app.