Wemo Connect App error

Ok. Man that hurts as I think it means all my rules break too when I delete and add back. This is one where I used the individual switches in the rules as opposed to a group. Knew that would bite me.

yea, it sucked for me having to remake some rules, but thankfully i'm not using too many in rules, so it was quick

1 Like

Thanks that worked for me. I also replaced the devices in my rules with groups just in case I need to do this again at some point. I did run into a weird issue with the one of my LIFX groups somehow being associated with my wemo lights when it didnt have anything within the group so I suspect there is something falling through there but once I added a bulb into that group it resolved it.

1 Like

Now I just need to figure out how to manually add the wemo mini switches which are not being seen with wemo connect.... for now I created virtual switches and am using IFTTT to manage them but its flakey when you try and act on more than one simultaneously. I'm having to inject delays.

Hmmm...from the errors in the log, it looks like the device is unable to call methods in the parent app. Note that devices must be added through the Connect app as they rely on a lot of shared code in that app.

I deleted all of the devices and re-added them all and they are all working now. With the exception of the new mini plugs that I bought. They for some reason don’t get discovered.

@dadarkgtprince I pushed out an update to the Connect app, the switch driver, and the dimmer driver that may resolve some of those. Try updating the Connect app and any drivers you're using. Also, note that devices must be added through the Connect app, not manually.

1 Like

in my case, all the devices were added through the connect app. i just had to delete the old versions and then they worked. i'll go through that again though tonight to test and let you know

@YapFlapper Another day, another update... :smiley:

I changed how manual IP addresses are specified, and fixed an incorrect variable name.

For the devices in your log that are showing 'null' for hexIp and hexPort, are those devices that used to work and recently stopped? Did you manually set any IPs or ports in the driver page of any failing devices?

on the new Dimmer code, i'm getting the following error when trying to save it

Cannot invoke method hexStringToInt() on null object on line 67

weirdly enough, i'm NOT getting it on the switch driver

I did the same and added them all through the connect app. My ips were all reserved right after adding so no chg there.

So yes they were working and then stopped. I did nothing to the devices on their page at all. Not sure what changed.

There's a new version of the Connect app and accompanying drivers. Hopefully this will help out with some of the issues that have been coming up.

What's new:

  • Ability to manually add devices through the Connect app -- give the app an IP address (like and it will try to discover the device at that address
  • Updated method for manually setting address and port -- use device preferences rather than a device command
  • Improved cleanup -- when uninstalling the Connect app, any child devices will be automatically removed
  • Everything has an importUrl now, so updating in the future will be slightly easier
  • Miscellaneous bug fixes
1 Like

Cool. Do you think this will make it so the wemo mini switches can be seen? I had just ordered a couple of these thinking they would work like the others and was just a different firm factor. In my backyard these things are instantaneous and very reliable compared to zwave which despite repeaters has never been (the yard is small so nothing impressive but does have a lot of cement/rock).

Unfortunately ifttt can’t handle multiple virtual switch state changes simultaneously and don’t allow multi-wemo switch changes simultaneously so the workaround gets really complicated.

That's my hope. Apparently the Mini's don't handle the standard discovery process in the same way as older Wemo devices (at least, that what it seems like, but I don't have any, so I'm not entirely sure), but possibly being able to manually add them will work.

Not sure where you are located but if you flip me your address I would happily send you one :slight_smile:

Is there any way to turn off the debug notes? I seem to get a lot in the logs since I’m turning on 9 switches on at a time in some cases.

There's a toggle at the bottom of the Connect app for turning debug logging off and on.

1 Like

even with that off, there's a lot of information being put in the logs. hextoInt and hextoIP seem to be the culprits

In the app connect code, i changed the log.debug command to debugLog() under hextoInt and hextoIP and it cleaned it up a lot for me

private hexToInt(hex) {
    debugLog("Converting ${hex} to int...")

private hexToIp(hex) {
    debugLog("Converting ${hex} to IP...")

Logging output was updated in the last couple of days. All the log.debug calls in Connect app were changed to debugLog in the last update (and the log statements in the hex conversion functions were removed).

1 Like

No. All DHCP.