Webcore notifications working?

New convert from smartthings here who is highly reliant on webcore. It seems you can only have 10 SMS notices per day, so I have to make some adjustments to my setup to use more app notifications vs. SMS, however, I'm failing at getting basic notifications working in Webcore. I've created a very simple script to test that it's working, and I cannot get any notifications to work. Can anyone please provide a pointer as to what I'm doing wrong? Thank you in advance!

Edit: Please ignore the "open for 60s" message vs. 30s check... this is a result of a few different checks that didn't work and I forgot to update them before posting.

iOS or Android?

Have you set your phone as a notification device in the WebCoRE settings on the Hubitat Apps page? Does sending push notifications work using Rule Machine?

2 Likes

I had the exact same issue. I found out that if you select the device you want the notice to and select ‘send device notification’ it will then push to that device.

Worked for me, hope it helps.

1 Like

Wow, thank you everyone for the quick replies. Awesome first experience with the community here! Turns out it was the settings page in Hubitat where you need to set your default push notification device, which I hadn't done.

@AverageJoe90 - that looks like it would work as well if I had multiple possilbe notification devices (which I want for other scripts), so I'll get that going as well.

Thanks all!

1 Like

Should the example above only notify the devices selected? I'm wondering if you can use WebCore to send notifications to only one device?

I have two notification devices. Both are enabled in the WebCore settings. In the example below both devices get the notification:

Any ideas? Thanks. Paul

I think the line you need to change is from "send push notification" to "send device notification." I haven't yet used it myself, but believe that is what will isolate it to the "Device App Paul" you have selected in the snippet above.

1 Like

as @myrison said change to device notification, should work then :+1:

1 Like

Awesome, thanks! Knew I had to be missing something obvious :roll_eyes: :grin: