webCoRE for Hubitat Updates

yes

you can do

if System Start event occurs

this is a virtual device named System Start.

There is an earlier note about this - note at startup the system is very busy initially initializing the JVM and apps and devices.

Ah, thanks for that! I kept searching for 'systemstart' and did not think about adding the space.

Have you tried monitoring for System Start events before in webCoRE? I set up a simple piston that just watches for System Start event but the last two days when my hub rebooted in the morning, it has not caught the event.

I have another one scheduled tomorrow and will see if that one triggers. I just have a simple like the one below:

If System Start changes
-- Log to console {$currentEventDevice} - {$currentEventValue}

I use System Start 'event occurs' instead of changes and it seems to work as expected.

1 Like

Thanks! I will edit my piston and confirm in the morning!

Edit: event occurs did the trick :slight_smile:

1 Like

@nh.schottfam , can you see my post here?.

Not sure if the piston just needs to be optimized to run differently for HE (I've got a C7), or if that code needs to be tweaked for the type of loop created in that sort of piston. I commented out that check and my holiday lighting piston has been humming along just fine for about 30 minutes now, whereas before it would be terminated 40 seconds after starting.

Upgraded to static String HEversion(){ return "v0.3.110.20200906_HE" } today and now the External URL endpoints are returning {"error":true,"type":"java.lang.Exception","message":"An unexpected error occurred."} and not executing. Any words of wisdom?

1 Like

Not sure if your situation applies but the webCoRE dashboard UI has been having a lot of problems in the last several hours. Problems were being reported from SmartThings users. Not saying your problem is related but more info to consider.

The ST issues on going are related to ST hosing their cloud (all that code runs on your local HE system...) so no relationship.

The issue was a typecast bug I introduced and it is now fixed.

3 Likes

My WebCore had a turn last night

I have OpenWeather and DarkSky's API, neither of them seem to fill in $weather

The LAT/LONG pulls up ok on the darksky's api site.

What am I missing here? A reboot?

Did you include the optional piece for the weather functionality

Hi, newbie to hubitat here. I installed webcore from a github link, then later installed package manager. Package manager also has a version of webcore.

I don't want to screw anything up, and I've searched but can't seem to find a definitive answer - could someone please tell me which I should be using? Github, or package manager? Ta

This is what I see:

You can do either, I would suggest Package manager, however. It makes it much easier to keep your version up to date. If you installed from GITHUB, there is an option under package manager called MATCH UP to scan you apps and it will setup package manager to keep track of updates.

How do I clear the red messages? This happened after a piston ran where I mistakenly set Store in Messages to true. I see @djh_wolf posted a screenshot with it, too.

Not 100percent what happened, but I went to github, cooy/pasted over both the Piston and the app groovy, went into settings and reset data (?) as advised in the first post's upgrade instructions. Deleted the package managers 2nd instance. Opened webcore, edited a random Piston and saved, and now everything seems back to normal.

Thanks for the replies!

1 Like

Got it! I use the Hubitat Package Manager, so I went in there and clicked Repair and selected webCoRE. I let it reinstall everything, then I went in and edited a piston and just saved it and it appears to have removed the red messages. Thanks for putting me on the right path!

1 Like

I tried searching this topic, sorry if it was mentioned before, I couldn't find an answer.

What is the correct formatting for passing an argument via a URL? The access token placement in the URL is different than Webcore in Smartthings (it doesn't have one)

For example:
https://cloud.hubitat.com/api/[hidden]/apps/68/execute/[hidden]:?access_token=[hidden]?somevariable="somevalue"

This just returns an invalid_token error

EDIT: Found the answer in another thread. I was wrong to use ? again

Correct formatting (for future search results):
http://cloud.hubitat.com/api/ HUB_ID_HERE /apps/ APP_NUMBER /ifttt/ EVENT_NAME ?access_token= TOKEN &start=START_TIME&end=END_TIME&description=TITLE

1 Like

Is this thread no longer a source for when the app(s) are updated? Header of the thread says the current release is July 26th and there have been numerous updates since. I've been using Package Manager for awhile but am going to stop using it for updating webCoRE. Why? Because it is loading webCoRE apps out of order and causing many, many, many.... errors in the log. YES, I know the errors are temporary but what a friggin mess.

Screenshot 2020-09-18 08.01.32

I'm going to continue using HPM as it is so easy to do.
So a 'one off' warning appears in the log. So what. It has no impact on the functioning of webCoRE or any pistons.
To call it a 'friggin mess' is a bit strong IMO.
Choice is good though.

Download the Hubitat app