webCoRE for Hubitat Updates

I don't see any errors at all in the logs.
The device remains set at 30 for volume but the code sets it to 59. The level never propogates to the device. If I do a Set Volume as a separate command ahead of the Speak command it all works.

There seems to be a problem with the latest hubitat fw I assume..

I did have to rerun the discovery the other day as my devices went on holidays.
I do use the Chromecast Helper from BPTWorld which seems to help keep thinigs talking.

Feature Request: Email

Now I know there is an email fuction already built in, but it would be nice if we could add our own email info to use instead of webcores email (I want to use my gmail account to send the notifications, and this way reduce the email webcore has to send. and is a preferred method for me. Maybe if it not entered it uses the webcore email, but if configured it uses the configured on instead.

Issue: Warnings appearing since updating to latest version today.

I have updated and now see these warnings, yet pistons work fine.

I have variables that I pre populate in data in the define, is this now an issue? if not can we get an option to hide these warnings?

I'll have to speak with Ian on way to control this.

That warning is real. We do see folks initializing a variable, then changing it, not realizing that if the piston restarts from the top (a new event; not wait/sleep and wake up), it will lose the setting they made. It does depend if the piston have multiple events that can start it executing.

So see:

1 Like

There is a sendmail device you can add that can use your own email service


Have a weird issue...I have the fireplace automatically turn off after 20 mins...it didn't work last nite so I changed the delay to 1 ,min and it worked. I changed it back to 20 mins and it did not work.
The log says that it did the speak and turn off of fireplace but in reality neither of those happened
In the logs is

Is that ok or is there an issue with those logs?

If I look in the device events, it says it issued the off as the last command

However the current state is ON

It seems like webcore did the right thing per log

I can go to device and turn on and off the fireplace with no problem

Any ideas how to trouble shoot?

Have you tried to set: Disable command optimization under settings?

I looked around and do not see where to do that... could you provide details?

Piston Settings > Command Optimization.

under webcore settings I dont see a place for piston settings ...but see the following

I dont see where piston settings is
under webcore settings i see

is that what you are talking about

No, edit the piston and then you'll see the piston settings up top, double click it.

See this link also, more visual.

In the body of the piston (you have to be in 'edit' mode) click on its title text and you'll see a Piston Setting box appear with a gear icon on the lower right. Click on the gear, then the command optimization setting (and a bunch of others) will appear.

Thanks ...sorry for being so dense...
I did the change and it appeared to work.... will try a few more times : )

Can you show us the piston?

working it out with nh.schottfam, ill remove the post.

1 Like

I have looked for a while now, but I didn't find anything, so here it goes: is there a way to set tile icons and background images in the Hubitat Dashboard from webcore?

Webcore and the dashboard are both seperate apps. They do not talk to each other in that way.