webCoRE for Hubitat Updates

Have you changed presence devices recently?

There are several "unknown" devices. It looks like your device list needs to be updated and/or you just need to go into edit mode and select the proper device for each instance.

It's an anonymized screenshot (Green button in WebCoRe)
The unlocking part works fine, it's the bottom if that doesn't run

I'm surprised that it worked before. Webcore doesn't normally trigger off a local variable as far as I know.

Correct just realised that it stopped working when I moved my last pistons from ST to hubitat mid September during code cleanup I made a mistake

Something is odd since I upgraded yesterday. I've been using WC for 5+ years so I'm pretty sure it's not me :wink:
If I try to move a With statement to a new position it just disappears. If I try to add (recreate) or paste the With statement into the Then of the Else If below the humidity conditions it either won't save or won't paste the clipboard contents.
I was in another piston this morning and the same thing happened. I tried to use the Move/Drop arrows and when I dropped to a new position the code just disappeared.

I'm not aware of any UI changes.

You can follow these:

I tried that and a reload from HPM but no luck.
Strangely enough I can add a new statement at 34 and 58 but I cannot save one at 49 ( or drag and drop to that location)

1 Like

Did a log trace. Not sure where the Token ERR came from, probably just after I cleared the security stuff.

app:122022-10-18 10:35:52.347infoUpdated ran webCoRE v0.3.114.20220203 HE: v0.3.114.20220928_HE

app:122022-10-18 10:35:38.932debugDashboard: Request received to get piston :b7047e7d6d22b711e65d27cb87cf9f33: Main Bath Lights

app:122022-10-18 10:35:21.589debugDashboard: Request received to get piston :b7047e7d6d22b711e65d27cb87cf9f33: Main Bath Lights

app:122022-10-18 10:35:16.958debugDashboard: getDb sending new db current: v0.3.114.20220928_HE in server

app:122022-10-18 10:35:16.528debugDashboard: get piston :b7047e7d6d22b711e65d27cb87cf9f33: needs new db current: v0.3.114.20220928_HE in server undefined

app:122022-10-18 10:35:16.456debugDashboard: Request received to get piston :b7047e7d6d22b711e65d27cb87cf9f33: Main Bath Lights

app:122022-10-18 10:35:12.348debugGenerated list of 172-194 of 195 devices in 304ms. Data size is 21141

app:122022-10-18 10:35:11.422debugGenerated list of 104-171 of 195 devices in 645ms. Data size is 42927

app:122022-10-18 10:35:10.167debugGenerated list of 62-103 of 195 devices in 585ms. Data size is 42367

app:122022-10-18 10:35:08.875debugGenerated list of 0-61 of 195 devices in 743ms. Data size is 46862

app:122022-10-18 10:35:07.521traceDashboard: Generating new security token after a successful PIN authentication

app:122022-10-18 10:35:04.645debugDashboard: error: ERR_INVALID_TOKEN m:dashLoad

app:122022-10-18 10:34:44.214infoUpdated ran webCoRE v0.3.114.20220203 HE: v0.3.114.20220928_HE

@ipaterson - any thoughts?

Another example on a different piston.
Original piston. I copy the last condition to the clip board and paste it in the New Condition line 35.
Paste from clipboard is there in Add a Condition but never shows up but the Complex empty If's expand - second png.

EDIT: I restored from a backup and the same error but if I paste to an Else it will work, just can't Drag/paste/add to an Else If. Either disappears or I can't Save the Task.

1 Like

I have seen pistons get corrupt particularly when using the copy/paste feature in the past, not the with statement specifically but this still sounds similar. Are you unable to drag and drop the with statement on all pistons or just a few?

I tried a totally different piston and same thing.
Copy line 45 and past to 57.
The paste fails but I can add a condition and task maually which I couldn't on the other example.



@nh.schottfam, Having some issues with graphs. I had not created a graph for a while but last week I modified an existing line graph to track humidity. After adding the additional sensor I went to the configure graph page. The sensor section was added but it shows the plot option, line options, etc. twice. Also I could not change the line color. If I select a color it just kind of blanks out.

I thought maybe it was just that graph, due to adding another sensor to an existing graph. Today I tried to modify the line color on another existing graph and I see the same thing.

Also if I change the line color and the selector greys out the graph will not display until I open it back up and then the colors are set to black. If I save it again without changing anything the graph will again display with black lines for the graph line I tried to change.

Here is the graph I tried to change line color on. One sensor tracking temp and humidity.

The 2nd screenshot shows the line color option when I start. In the next screenshot I tried to change the color to red, it is greyed out. Now the graph will not build, see screenshot 4, until I reopen and re-save without changing anything and the line color will be back at black.

Last screenshot is the log for the graph that will not build.


Hey guys. I been away for awhile, because everything has been working great. I am trying to make some adjustments, but cant get to my dashboard. It just never gets past loading.

I read thru, and dont see any changes, am i missing something here?

Try clearing your browser cache or using incognito mode.

I've noticed recently (within the past few weeks) that after saving a piston and "Finishing up..." is displayed, the editor doesn't drop me back into the main area that shows all of the pistons. I have to click on "cancel" or "save" multiple times get that to happen.

I suggest for both of these:

1 Like


I'm trying to host my own local WebCoRE server on a Synology DS220+. I'm running into an infinite URL rewriting loop, where it keeps redirecting me when I try to access the site. Has anybody been able to get this running on a Synology?

Interesting. Could you tell me the benefits (assuming you get it sorted :slight_smile: ), and where I could find more info? A quick google didn't find much??

I had it working on a different brand's NAS, then I upgraded to a Synology and I can't get it working on that. It was really easy on the other one...