webCoRE for Hubitat Updates

I'm sorry, I cross posted to this thread.

https://community.hubitat.com/t/webcore-and-hubitat/85589/6?u=c33jd13s3l

Yea I have WebCore running local but only my global params show up. I am try to debug the device list missing when I install locally and refresh the auth token in hubitat to run local instance, still not seeing devices locally but I see them on the webcore cloud dashboard.

You should clear your browser caches.

You should also enable full debugging for the webcore main app and see if anything shows up in the logs.

The IDE loads devices from the HE system. There is no cloud functions, it is all HE system -> your webbrowser

2 Likes

Thank you @nh.schottfam that worked. I have pihole and webcore local running together on a single pi zero w and no eth0. Still very responsive.. gonna upgrade it to zero 2 w this week. Let me know anyone wants the install scripts, again it is on pi zero 1st gen, raspbian-lite,

:raised_hand_with_fingers_splayed: me! :raising_hand_man:

Me too!

Here are my current scripts.. this is hardcoded to 0.214.. change the static IP to whatever you want. I copy the files over with WinSCP so you would have to add the ssh commands as needed. I also leave a few files owned by www- so it's certainly not secure.

Here is the code to write dhcpcd.config after first install, ssh and supplicant are installed, then dhcpcd hardcode the IP with your input.

"sudo chown pi:root /tmp/dhcpcd.conf",
"sudo chown pi:root /etc/dhcpcd.conf",
"cd /tmp",
"sudo mv -f dhcpcd.conf /etc/",
"sudo chown root:root /etc/dhcpcd.conf",
"sudo reboot"

@nh.schottfam

I found a regression in the latest webCoRE update that I installed a couple of days ago (with the fixes for stays): it treats device number variables as strings instead of numbers, so date/time functions fail.

Use this sample driver:

metadata {
 	definition (name: "DateTime bug sample driver", namespace: "test", author: "Daniel Segall") {
        capability "Initialize"
        capability "Refresh"
        attribute "time","number"
     }
 }

List<String> getModeOptions() {
    List<String> options = new ArrayList<>()
    for (Object mode : location.getModes())
        options.add(mode.toString())
    
    return options
}

def installed() {
    fullReset()
}
 
 def initialize() {
     fullReset()
 }

def refresh() {
    fullReset()
}

def fullReset() {
    sendEvent("name": "time", "value": new Date().getTime())
}

Create a virtual device, add it to webCoRE, and this example piston will demonstrate the issue:

It produces the error

║Error executing func_formatdatetime: java.lang.NumberFormatException: For input string: "1.640263963672E12"

1 Like

Hopefully someone can help, I am experiencing big delays loading the dash with chrome. It can take up to 40 seconds every time. I've tried clearing out files and cookies with no improvement.

Anyone else experience this?

You might want try logging out and back in.

Same, this has been persistent and seems to be worse sometimes than others. It's definitely happened to me enough where I notice.

I also get this flash of something in the background sometimes when it loads. It looked like a new webcore logo multiple times but then after the last update it flashed with what appeared to be a web page of some sort. It only flashes for a brief second when its logging in so it's hard for me to tell what it is and it's the same point where I've noticed the delays.

Hi

Do you see the same thing both on dashboard.webcore.co and staging.webcore.co ?

@ipaterson - any thoughts?

I'm good on both dash and staging.

Dashboard.webcore.co is the primary way I access it so I'd say thats where I've been witnessing it. I just tried it again and while there was a decent 20+ second delay, I didn't see that flash of a page but I've only noticed that occasionally. When I see it again, I'll report back but I know I saw it at least 5 times in the last 2 weeks. I just assumed it was upcoming changes tucked beind a flag that were for some reason sometimes rendering for a split second but it wasn't enough to alarm me.

Do you ever notice the save glitch? Sometimes after I click save it will either wait good 15 seconds before redisplaying the piston or just stay there forever.

I haven't noticed anything with saving pistons (and I save pistons every day). I've gotten a save error twice but I think in both circumstances it was because I had two pistons open saving at the same time.

Well, I say that but... I've noticed no more delay in saving pistons than what I'm used to and its within what I consider reasonable.

It just happened again and this time I DID get a good look at the page that it flashed. It absolutely flashed a page about the new Matrix movie for a brief second while it was taking 20+seconds to load my bedroom piston. Maybe its an ad?
Ghosts Im Not Crazy GIF by MIRAMAX

mine always takes about 40 secs via https://dashboard.webcore.co/

Been that way for a loooooonnnnnnng time. Months.

Registered browser at https://staging.webcore.co/ - 3 to 4 secs loading time.

are you running any blockers, like pihole?

Hi there, I'm brand new to WebCoRE for HE; however I've been using the WebCoRE for SmartThings for several years. I was importing many of my pistons this morning and noticed that WebCoRE for HE cannot divide variables. For example, if you create the expression 4/2 the result is 2; however if you create the expression varable4/variable2 the result is either 0 or 1. WebCoRE for SmartThings correctly divides the variables. Anyone notice this or have a possible solution?

Download the Hubitat app