WebCore Error: There was a problem loading your devices

I'm getting the (well known?) error "There was a problem loading your devices. The data shown below may be outdated; please refresh the page and try again."
I've added two devices with the HE webCore app imported a piston from my old Smartthings webCore location. After that, I started getting the error.
I have tried all the usual stuff such as refreshing the web page; logging out of webCore and registering a new instance; tried on a different browser; tried a different PC and browser; rebuilding the cache, etc.
I'm on the lasted version of the webCore app.
I've gone into the webCore app and made sure the new devices are in the list of authorised devices and clicked to the end of the process of adding devices so make sure there is no issue there.
I have also restarted the hub.
Any ideas?
Maybe I should add that my hub crashed about 3 days ago and I had to do a soft reset to get it going again, but I have not since noticed any issues with webCore. I did not make changes to any of the pistons since then and only started getting the error after adding 2 new devices to webCore after adding the two Z-wave devices to the hub.

So I would again check that all the items here have been done in order. Again my experience so far is 99.9% of the time this resolves it.

You can try staging.webcore.co also as a site.

If you are sure webcore is installed properly, has hub has been rebooted properly, passwords are correct, there are not two instances of webcore installed, etc. Come back and we can work it in a private message

Thank you @nh.schottfam. I'm somewhat freaked out at the moment.
Considering the checklist:
The hub is running the latest firmware and webCore is up to date (with approximately 40 pistons)
I ran Package Manager's repair function
I have only one instance of webCore installed.
All pistons seem to be running fine.
I have not made changes to any pistons in recent months (this hub is at my holiday home and I've not been here for a while.)
I had a power failure on Sunday which resulted in the HE Hub to become corrupt. I did a soft reset and restored the most recent backup (which was about 2 days old.)
As indicated in my initial post, I logged out of webCore; tried incognito mode; cleared the webCore cache and cleared all security tokens.
I only noticed the error after I duplicated a piston from another webCore instance.
The 2 Devices I added with the HE webCore app, are not available in when editing a piston. I tried removing the 2 HE devices I had added to webCore and adding them again, but still they don't show up when editing a piston.
The error appears on the dashboard:

I'll appreciate any help immensely.

Edit: I have now again done a soft reset of the hub. (Backed up the hub, did a soft reset and restored from backup.) Same issue unfortunately.

Edit 2: Things seem to be worse after the restore. If I open (edit) a piston, it will not save afterwards. I notice the following errors in the hub logs:

ok, strange.

are you comfortable editing some code? I have a fix but I wanted to see more debug information on the error. If you don't want to, that is fine, I'll push the fix out shortly.

ok, fix pushed, hpm repair to get it

Would like to see log messages from it with new version. It Is something about devices I want to see

1 Like

If it is simply a matter of copying code to the app's code, I'm sure I'll manage.

I'm no longer getting the error after the update. The new devices still did not show up when editing a piston. So I removed the devices from webCore (unticked the devices in the app, saved through) and then added them again.
They now show up when editing a piston.
It this what you're looking for in the logs:

so what device is that?

I assume a customer device, can you point me to the git so I can go look at the sources?

I have also gotten this error, hopefully it will be fixed in this update.

java.lang.IllegalArgumentException: Handler method cannot be empty on line 3311 (method pageFinishInstall)

I doubt that the 2 devices I added, are causing those errors. I added two Fibaro keyfobs using a generic Z-wave button driver.
Looking at the errors, the only driver I can think of that could cause those errors, is the Samsung TV driver.
To assist you: I've been using the driver for some time without apparent issues. I don't look at the logs often, but I would have noted those messages by now - but anything is possible.
I deleted the piston I copied over from the other hub earlier today and tried to import it again now, but the import now fails. For what its worth, the piston is not using the Samsung Remote TV driver device.
Edit: I just realized that after doing the webCore update just now, I randomly opened a piston to check if I could see the newly added devices, and the Samsung TV driver is used in the piston I opened.

Webcore recently added more code for processing custom commands from devices (to give to the IDE), and it was some of this code that go angry.

Look at the command definitions in the driver, they do not look correct to HE specs. That said the workaround I gave you should resolve the issue regardless.

The command arguments are supposed to give a type for the argument, which is not what this driver writer is doing...

Anyway you should be good now.

Your quick response is sincerely appreciated.

There does seem to be an issue still. As indicated earlier, I logged out of all webCore instances in my browser. I subsequently re-added the hub (Hub B) that was giving trouble and I have now also added my other HE hub's instance (Hub A), to copy a piston from Hub A to Hub B.

As soon as I add Hub A, I'm unable to switch to Hub B's instance. Selecting Hub B's instance, takes me back to Hub A's instance. I.e. I'm able to select hub B, but the interface doesn't switch to Hub B. Don't know if this could be related to the current issue?

Don't know if this is important, but I have not updated webCore on Hub A with today's webCore update.

ok, my suggestion here:

You have two HE hubs, each with webcore - correct?

If so then:

  • log out of your webcore IDEs. (ie anything using dashboard or staging)

  • On each hub,
    HE console -> apps -> select your webcore main process
    - Select settings
    - select security
    - select 'Set custom account identifier'
    On both hubs use the same Account identifier (it can be what you want no spaces, but the same on both hubs)
    For 'Location identifier' give each hub a separate one (again they can be anything not spaces) but they are different / unique for each hub

    save / done you way out of each hub

Wait about 1 minute, then you can re-register your webcore IDE (dashboard or staging)

  • this should straighten out any issues.

What is going on:

  • Smartthings has a common identifier for you for your account. Such a thing does not exist within HE so you are manually creating it (ie the same account), and then you are giving each location its own unique identifier).

Thanks, will try that tomorrow. (For the record, it has been working fine for some months, but I'll do as suggested, thanks again.)

Did someone say there will be an update to fix this issue that was already released to HPM?

I've been checking all day and there are no updates.

You need to do an 'HPM Repair' of webCoRE to get it

Am I experiencing the same problem as this thread OP?

Your issue seems somewhat different. I would start by forcing an update of webCore as explained here.

I did that :wink:

Is there any reason to hpm repair if I'm seeing any issues in the logs?