Web layout bug -- modal popovers appearing under content

When I use the hubitat control panel on my desktop (Macos, Firefox 75) sometimes when I click a button which triggers a popup modal, the modal appears behind the content rather than in front of it. No errors show in the console.

Here is a screen recording: Hubitat GIF | Gfycat -- put it in HD mode, and disable "Autoplay related GIFs" and hopefully you can track what I'm seeing.

It's not possible for me to see what you're doing in that video, lacking all of the context you have.

Is this reproducible with Chrome?

You’re right, that was a terrible guide for what I did. I was in a hurry to get it up—sorry!

Here’s what I did:

  • browse to applications
  • click “add user app”
  • modal shows up behind the list of applications*
  • in the inspector, I select the modal and add a zindex: 10 property to it
  • modal shows up in front of the applications *

I selected the modal by way of selecting the modal button which does not appear behind the list, it appears in front.

I haven’t tried Chrome. I do know that the same behavior existed before the recent set of update/patches of the last few days. It did work recently though. I’ve only had the hub for a couple months and it worked when I got it.

I do know that it works on my mobile safari just fine, and that has been my workaround.

I have a few content blockers on my browser, but none of them seems to have blocked anything.

None of the UI code has been touched since you got your hub. I cannot reproduce this with Chrome on a Mac, or Safari, or Firefox.