Wait for Expression stopped working

At some point in the past week, two rules I deployed stopped working. They are nearly identical.

Since this was working for over a year, I assume there is a bug in a recent update.

I’ve attached a screenshot of one of the the (fairly simple) rules.

image

(In the interim, I changed the logic for the rule so that my doors auto lock after a time)

1 Like

I'm not aware of any known issues or other reports that sound like this issue. Do you have logging enabled for the rule? If not, enable all logging for the rule and see if "Logs" provide any clues about where things stop (or if they never actually start--or if it's really the device acting up, etc.).

Hitting "Done" in the rule will also re-initialize some things, including re-subscribing to your trigger events, in the event that something happened to those and caused the whole thing to not work. Just something else you can try in the meantime.

I have many rules that use wait for expression and all are working here.

Have not observed this either. I have many rules as well and all seem to be working

Not sure when it isn't working what triggered it but could it be the door contact sensor battery is dead so the trigger isn't firing?

Hitting "Done" to re-initialize. I think this fixed it.

A bit more history. I had two rules, for my front and back doors. Both stopped working around the same time. Today, I changed the wait from 2 minutes to 20 seconds (for troubleshooting purposes) on the front door rule, and it just started working again.

I tried the back door rule, which still had the original 2 minute wait. It was not working. Changed the wait time and it started working again.

Download the Hubitat app