Wait events not working

This rule worked and worked well. I set it up so that it could run to completion or re-trigger and work through as needed. It was perfect. But....for the last few weeks, it has stopped working. It's always at the same point. It's a wait for event on the downstairs door opening. The rule is waiting, the door opens, the log shows that the rule sees the door open, but it never advances past the wait. I have a another rule that is doing the same thing. The wait events don't ever advance when the event happens. What can I do to fix this? It's frustrating because this particular rule pauses others and was designed with timeouts so that if it didn't run all the way through, it would still complete and un-pause the affected rules. Now it won't advance past the wait and they all hang...so nothing works after this rule starts.

The rule:

The log (with notes to the right):

The log with the rule, wait event, and the door contact log:

The hub sees the door open...so why is it not advancing the rule when the criteria is met? As I understand it, the required expression should be able to be false and it not affect the wait event, is that correct? I've made sure it isn't cancelling any pending actions:

Try hitting "Done" to reinitialize the rule and see if it starts working correctly again.

1 Like

If you don't mind the time to do so. Rebuild the rule from scratch and suspend this one. See if the new one works. I have had that fix misbehaving rules before.


I've done both reinitialize and rebuild the rule. The waits time out at the same place and stop working. I can't see any reason this is happening.

When I troubleshoot a rule that doesn’t work as I think it should, I clone it to make a copy, then stop the original from running. Then I comment all (or at least at the point of presumed failure) commands in the clone. Then I start uncommenting working my way through the rule testing it. I have also found that running a rule’s rule may result in different operation than if the trigger initiated the rule.

There’s always the issue of firmware updates and other changes that shouldn’t matter.