Wait event not triggering

This has happened for a few days in a row and I just don't understand it. I'm not sure what to do to fix it either. I have a rule set up to look for inactivity in the room. If the room is inactive for 20 minutes, capture the lights as they are, then turn them off. Wait for eight minutes to see if motion reactivates. If it does, restore the lights as they were, if not, exit the rule.

It works pretty much every time, and worked right before this time that it didn't. It did the same thing yesterday. Worked a few times in a row, then didn't. It appears it's not seeing the motion turn active during the wait. Any advice why the motion activation is not passing through to the wait for event?

I know the required expression is false, but I don't have the cancel pending waits enabled on the required expression. And it's worked in that state before because the rule is active when the lights turn off.



image

Can you select both the motion sensor and the rule from the past logs tabs and show the logs messages starting with when the rule was first triggered?

I think this is what you were asking about. I highlighted the part where I just turned the lights back on...kind of to mark the end of the thing. I tried to activate the motion several times before I realized it wasn't going to work.

This is earlier today when it worked correctly. This may not help, but I wasn't sure if you might be able to see something in it compared to the other that didn't work correctly.

Interesting. The only thing that stands out from those logs is that, in the instance that didn't work, it turned both lights off. In the instance that did work, it only turned off the can lights.

I wonder if the double change in the required expression is causing problems. Maybe some more testing there will shine some like (e.g. turn on one light and see what happens; turn on both lights and see what happens).

I thought I might have selected the command only switches that are on (however it's worded). But I just checked and it's not selected. I'm not sure why it would have turned off just one when both were programmed.

I'm just not sure what the deal is with it. I'll have to watch tomorrow and see what time (IF) it doesn't work. Throughout the day today, it worked multiple times after this post. I'm just not sure what the deal is.

Thanks for helping! I appreciate your time!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.