Volunteers wanted-Ghost Busting Trial

So since I've had some success in the case where a ghost appears and the "Remove" button under Z-wave details does not work. Now this works only in the case where the device is powered up and you can activate the z-wave pairing sequence on the device.
What I observed is that even tho the device is powered down, the remove button will not remove the device. Well what has worked for me the last several times, was to go to "Add Device"-> "Start Z-wave Exclusion" and perform the particular device's exclusion sequence.
This just worked not 2 minutes ago with my Aeotec 7 repeater. It became a ghost(route box blank) and would not remove using the remove button in Z-wave details, even after many tries. However the very first time I started Z-wave exclusion from the "Add Devices" button, and tapped the repeater's button and instantly the ghost was gone.

If anyone has a ghost I'd be very curious if this method works for you. Obviously if the device is dead or otherwise inoperable this will not work.

I would not call that a ghost node at all, the device was obviously still attached to that node if the exclusion removed the node.

Just because the route box is blank that does not mean you need to remove the node?

Also, if they device has been factory reset, or paired to another node ID, the exclusion wont remove the ghosted node.

Interesting because it was non-responsive, route was blank, a click of refresh produced a remove button, plus it was failing range tests, which is what I've seen before with ghosted devices. Maybe I'm using the wrong term here, but in the state it was not functional. Plus the Z-wave plug that was routing through the repeater became unreliable, which is what prompted me to check it out.

Sounds more like the device was locked up to me.
Did you try power cycling the device and the hub before you did the exclude?

A true ghost node would be where no device is attached to the node anymore, such as if the device breaks, is factory reset, or a failed pairing and the device ultimately is paired with a different node id.

It is odd that the device was unresponsive but somehow was able to send out the exclusion data.

I just tried this with a Leviton DZPD3-2BW and got confirmation of the exclusion:


However, the ghost node still shows on the Z-Wave Details page. The remove button still does not let me remove it from the details page:

Like I said, the exclusion will only work if it still has that node attached on the device itself. Once it is reset, excluded, or paired on another node it is no longer tied to the old node. No idea why the remove randomly doesn't work besides that the SiLabs SDK is garbage.

1 Like

Interesting, mine actually said the name of the device when i excluded it. I'm guessing like @jtp10181 said, it wasn't a true ghost.
I wonder if you hit the remove button in the z-wave details, if it will go away.

Nope. Still there unfortunately.

I don't think you should ever see that unknown device message unless the device being excluded is not in the Z-Wave database of the hub you're excluding it on.

Something's not right here...

Simple explanation, the device was already factory reset before running the exclude.

1 Like

OK, thanks. I didn't see any comment that he had done a factory reset on the device first. Must be missing something...not unususal for me. :wink:

They did not say that was the case, but its the only explanation, it was either factory reset or excluded / included on another controller. Could have been factory reset due to some other factor like a power sure or who knows what, but somehow the device lost its memory of the hub and/or node ID it was attached to.

I hope that's the explanation otherwise we have something new and weird going on. :dizzy_face::wink:

Download the Hubitat app