Virtual Switch not showing in WebCore piston

I am trying to setup a WebCore piston using a virtual switch. I see the virtual switches I have already added in the Device List of the piston, but even when I click on devices, check the box of the new virtual switch and click Done, it does not show up when I display the piston. After the Update, the device shows in the list of available devices, but never make it to the piston. Anybody had this problem? Thanks, John Vowell.

few questions

  • in webcore, ensure you go in and check the device selections (settings), and done/next your way out.

  • What are you using for your webcore IDE? ?

  • if this persists would need to see some screen shots to fully understand what is happening.

First, I went to the website in your reply, but it asks for a verification code that I do not have. When I clicked on how to find the vide, it indicated getting it from SmartThings, but I am using Hubitat, so this confused me.

In any case, here is what I did with the resulting screenshots:

First, I clicked on the WebCORE app in Hubitat,, and chose create a new piston which displays this screen

I entered the new piston name and clicked create, which got me this screen:

Found the problem. I remembered that, when I first got HE and added the Lutron interface, when I added all the Lutron devices, they would show, but nothing worked with them - on/off, etc. A friendly HE user suggested I try adding them with my PC instead of my iPad. I thought, “Why not try that with the case of the missing virtual switch?” And lo and behold, it worked. For some reason, HE seems to do some things better on a PC than a mobile device. Go figure. Thanks for your responses.