Virtual Keypad Issue

I am having some issues on getting a certain part of the Virtual Keypad to work in a way I would like it to; I used this guide to create it and it works great except one part: https://community.hubitat.com/t/release-virtual-keypad/51825.

When I originally setup the keypad I used custom Arm Away settings, this allowed the HSM to notify me to Please Leave when I clicked Armed Away button.

After reading through the post linked above I realized I didn't have my keypad properly setup, so I changed the settings to what I read in the post and this fixed my keypads operation so the counter worked.

Unfortunately as you can see the Please Leave blue box in HSM does not appear anymore.
I believe this is because the ArmingAway setting isn't registering with HSM when going through the keypad settings.

I tried creating rules for this but the only ArmingAway status I could find is at the beginning of the IF in the IF Then option, not at the end where it would be more useful. Am I missing something here or am I out of luck with having both options working on my keypad.

Thank you

Hey, I understand what you are asking. It wont currently function that way. I initially made this keypad because I couldn't get hsm to work as I wanted it, including the delay exit function.. probably didnt give it enough time...

regardless, I built this to operate with, but separately from hsm. So the keypad timer function wont work directly with hsm delayed exit as it was designed to replace the functionality. This is why its recommended in the instructions to set the delay exit to 0 in hsm when using the keypad timer.

I missed that bit, I'll make the necessary changes and remove the HSM tile from my keypad.
Love what you have done and Thanks Much for this, I would rather have the timer than the Leave Now Message, the timer really says it all.

1 Like

Download the Hubitat app