Vesternet Zigbee 8-button

I have just bought one of these:


They don't seem to have got round to publishing the driver for it, but have done one for their otherwise identical 2-button device. I could fiddle around and see if I can adapt it, but before I do, has anyone already written it?

After receiving this I paired it and it automatically got assigned to the RGBGenie Button Controller which recognised all its buttons and capabilities. So I am sorted :slight_smile:


I have just added one and it sees it as the RGBGenie Button Controller too however I don't receive anything from it when the buttons are pressed, if I check events it shows nothing. Am I missing something? Also on the buttons themselves, I only get and LED indicator flash when I press the "I" on buttons and nothing when I press the "O" off buttons. Is this normal? I have even used Vesternet's own driver for this (Vesternet VES-ZB-WAL-012 4 Zone Wall Controller) and again it appears to do nothing :frowning: Do you have any suggestions?

Have you tried with the device very near the hub just in case where you have it the signal cannot reach? Otherwise it may just be a faulty device. I guess you could try removing and pairing again....

Thanks @Inge_Jones for your reply. This was doing my head in, it was only by clicking around I tried the 'add device by brand' then selected vesternet 8 button controller, paired it and it worked like an absolute charm

1 Like

I bought the same controller and I've paired it with HE but none of the button commands seem to be coming through. Exactly the same behaviour 'Evolving.Home' was describing above. I did initially try adding device by brand and choosing the vesternet 8 button controll option but that didn't work. I then tried removing and readding it a couple of times but still not working.

Any ideas what may be wrong or how to fix it? This is what the log shows immediately after I first paired it:

I managed to resolve this. For some reason one of my powered zigbee devices (innr wall plug) wasn't playing nicely and it kept booting off the button controller. I unplugged it from the wall and then paired the button conroller and it was working perfectly. Then I put the plug back and everything is all good.