Very slow Hubitat response times

I recently switched over from SmartThings and am having very slow response times with some of my automations.

I have an automation to turn on the light and vent in my restroom once the door is opened, however, it is takes 5 seconds on average or sometimes even more before the light and vent turn on. With ST, it was almost instantaneous.

I have captured logs and there is quite a delay between when the hub receives the message that the door is open, and when it sends the command to the light and vent to turn on.

Any idea what may be causing this, or what I may be doing wrong?


Can you post logs, and what app are you using for the automation?

Not letting me embed screenshots. Wonder if it's because I'm a new member :slight_smile:

I've tried webCore and Rule Machine with same results

How long does it take for a command from the web interface to happen.

Might be mesh issues... I'm assuming you're using the C7 hub given that you've recently switched over. What devices are you using? Z-wave, Z-Wave Plus, Zigbee?

If you look at z-wave details do you have any ghosts? What apps are you running on HE overall? (Doesn't even have to be rule machine, looking for errant 3rd part apps) Are the slow devices using the correct drivers? Have you tried alternate drivers?

From command to web interface, less than a second. From web interface to execution, 6 seconds during my last test.

No mesh issues. I completely excluded all my devices and methodically added back to make sure no crazy hops. All Z-Wave Plus devices.

I assume you are on the latest update and you updated your zwave FW... After that I am out of ideas other than a soft reset.

could be the battery issue.. is it onlyslow after not using the contact sensor for an extended time?

1 Like

What is your method to determine this? There are issues with certain devices that want to join with S0 which is a crazy amount of overhead and runs poorly on the 700 Z-Wave chipset. Have you determined that manually operating the devices from the device details page operates it quickly? If it's slow there too, then you likely have a device issue, not a hub issue.

Helpful to offer the community what make/model devices you're talking about. Just saying Z-Wave Plus doesn't mean much since there's still so many other variables there among brands and versions. New members cannot immediately post images. You'll need to post more before Discourse will allow it.

To me...

If the end device is consistently fast when operated from the device details page, but not from the RM rule, then it is an RM issue (ether the rule itself, or the app).

If that's the case maybe change the title of this post, or make a new one specific to RM to get the right people seeing it.

Or if it is a simple automation, maybe try the simple automations app instead of RM. When I tested it, Simple Automations was always faster.

1 Like

Operating the devices from the details page is almost instantaneous.

The sensors in question are the GE Enbrighten Z-Wave Plus Door Sensors and the switches I'm trying to control are Zooz ZEN30 double switches.

Thanks for your help. Much appreciated :slight_smile:

Yes. On the latest update. Will try a soft reset to see if any improvement.


Thanks for the additional info. Some Zooz devices have been giving a lot of people issues when more then one or two are added to the Z-Wave network. However, you say the manual operation from the device details page is near instant. So then how about the door sensors? Watching the Door Sensor "Current State" on its device page, do you see its state change instantly when it's triggered, or do you see a delay in the state updating?

A soft reset may help if there are database issues. Backup locally and then try that. It's simple and non-destructive (as long as you have a backup to restore from). If that doesn't resolve the problem, I would suggest creating virtual devices and substitute them in the rule to see if the virtual devices respond quickly, or if they are also reacting slowly. If virtual devices are also slow, then I think it would help if we can see your rule. If it's a simple rule, it will be worth just recreating it to see if there's a difference in performance. Rules typically just work, but they're not completely safe from getting messed up. Especially when you're still learning Rule Machine. You can do a lot of edits and backing out of steps when creating a rule, but I've found that on occasion, too much of that may corrupt the rule. In those cases I just need to build a new one.


I didn't see you mention which Hub Platform version you are using.
If it is 2.2.4, and if the door sensors are using the Generic Z-Wave Contact Sensor driver, try changing them (and any other contact sensors you have using the generic driver) to the "Ring Alarm Contact Sensor" and see if things improve.


Correct - 2.2.4. I’ll try changing the sensor type as suggested, then I’ll try a soft reset.

Thanks for all the suggestions - very helpful community.

Changing driver to Ring Alarm Contact Sensor seems to have resolved issue. Thanks much.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.