Very new to Hubitat. As in, VERY new. Questions about dashboards

Check this setting. Apps, Hubitat Dashboards, select which dashboard you want to work with.

In that dashboard settings section at the bottom, open "Advanced".

I had already set those settings. But the problem is still there. NOT when just opening the cloud link in the browser on my mobile device. THAT works.

However, I do not see that dashboard in the 'dashboard' tab in the Hubitat Mobile App.

So you're saying that if you click here on the mobile app:

You don't get a list of dashboards like:

That is EXACTLY what I'm saying.

Have you tried rebooting the Hubitat Hub from its Settings menu? Just an idea as it seems you've already tried most everything else at this point. @bobbyD may have some other tips.

then you may be interested in this [RELEASE] Hubitat Dashboard - Android dashboard app

I have it on my phone and all of the pads in my house. It's amazing.

1 Like

Just tried this. Same result.

1 Like

It also does geopresence and notifications, FYI. :slight_smile: But for all of these features, there are also ways to do it without the app, which is newer than the hub/platform itself--and with Dashboard, we're particularly lucky in that it doesn't need a third-party app or service (compare: you still would need something to get notifications without it, like Pushover).

If you haven't tried my suggestion above of logging out and back into the app, removing the settings, or just uninstalling and reinstalling the app (I'm assuming this also removes settings on Android; it does on iOS), that can't hurt. @ogiewon's suggestion to reboot the hub might help, too (EDIT: I see as I was writing that it didn't). Since he's also tagged Support, they'll probably have other ideas. This is an odd problem, but hopefully someone will get it figured out! In the meantime, I'm glad to hear that at least the cloud URL is working for you.

2 Likes

Which device and version of Android?

1 Like

the only thing i can think of is you put the tile in the middle of the dashboard, and you need to scroll on your phone. can you confirm if the tile is placed in row 1 column 1, then try it in the app? force close out the app and reload it to make sure you're looking at the latest version of the dashboard

So back up a step. Maybe I missed it above, but did you in the mobile app select a hub?

Settings, about 4 items down, click on that and pick your hub?

Well, yeah, I ofcourse do understand that the app does a bit more than just provide dashboard access (or not :wink: ) but it would be nice to have everything in 1 app, instead of installing 2 or 3 apps or having to go to a web url to do something that should just work from the app.

I have NOT tried uninstalling it, but I HAVE just tried logging out and then logging in again, but that does not solve the issue either.

Another thing I just noticed as I logged on again...my geofencing was also gone. I had to go into the settings in the mobile app to turn on geofencing, and than it worked again (including the correct location) but it IS kinda weird that it just disables that setting?

Anyway, having a lot of trouble with the correct use of then vs. than. As you all have probably guessed already, English is not my native language. Dutch is. :slight_smile:

Also, I have just removed the app, reinstalled it, logged on and...there are the dashboards? So, success!! however, it introduced a new issue. I only have 1 phone. That is a Samsung Note10+. However, it is now present as a device in Hubitat...5 (!!!!) times. Everytime I log out and in, 1 device is added. What's more, I have created 'rooms' for Hubitat on my laptop. Those rooms I see.

I have added 1 door sensor. That sensor is placed in one of those rooms. In the app, I don't see that sensor in that room. I don't see it anywhere for that matter. If I 'open' the 'room' that it is in, it does not show up in the mobile app. :thinking:

Another weird thing I noticed (I have not been able to post more messages because of a limit of 25 or something in the first 20 hours??). Because I logged on, it started asking me if it was an existing device, or a new one. Even though I said existing, it added a new device. The weird thing is, in those 'new devices', I COULD see the dashboard in the mobile app???

If I logged on as the 'original' device, I could not. Now I have removed all mobile devices, logged out and logged on again. At the moment there is only 1 mobile device but I can NOT see the dashboard. This is very confusing.

Android 11 on a Samsung Note 10+ .

Right, since last night I could not post anymore because of restrictions as a new user, my last 2 posts are a bit....late. Let me start over:

I have 1 hubitat.
I have 1 phone. Samsung Note 10+ running Android 11.

I am just fiddling around with Hubitat. Nothing serious yet, as network is going to change in the next weeks, so just trying stuff so I kind of know how to work with Hubitat. Allright, so:

At the moment, the situation is as follows. I have installed the app. I have logged on to the app. In Hubitat, I can see my phone. I renamed it. I have added 1 door sensor. I have used that sensor for a simple rule that my phone receives a notification when sensor is opened. This works.

If I open up the app on my phone, I see NO dashboard, even though I have created one. Before, what happened, is when I logged OUT of the app, and logged on again, even though I selected 'existing device', it added a new device, meaning that in 'devices' it now had 2 phones. I will try that again now.

Logging out...
Logging on...

It shows me that there is a known device. I select that device.... logged on. Right, so, now a few things happen:

  1. It has added a 2nd device. If I go to devices on my laptop, I see 3 devices total: being 2x phone, 1x door sensor.
  2. Geofencing is turned OFF even though it was turned on when I logged out. Turning this on again in the settings retrieves my home location, which is correct, but why does it turn off?
  3. I have NO visible dashboard in the app.

Logging off again...
Logging on again...

It now has 3 devices. 3x the same phone. I am selecting the 2nd one..

  • geofencing is off.
  • no dashboard..

I can repeat this, but everytime it will add a new device, with the same results... I don't understand what I am doing wrong.

It sounds like it believes that you are setting up a new mobile device each time. What happens if you just close the mobile app instead of logging out?

If i just close the app, no new device will be added because when I open the app again, it is still logged on. No new device is being added.

However, why does it add a new device even though I am selecting an exising device from the list (everytime I log off and on, that list gets +1 entry).

That might be a bug and I'll add @bobbyD for tracking down that. For now I'd stay logged into the app and see if that works better for you, i.e. GeoFencing and Dashboards.

(Thinking about it, staying logged in may be the proper way of using the app for GeoFencing and receiving Notifications.)

Well, if I stay logged on, it will NOT add a new device and geofencing is not turned off, so that works fine. However, I do not see my dashboard.

If I open up the dashboard in a browser on my phone, I see that, and it also updates correctly, e.g., if I open the door sensor, I see the status changing of that sensor, which is good.

I just don't see the dashboard in the mobile app.

Hopefully bobbyD will weigh in shortly, and check that out too. Probably just a setting somewhere that I'm forgetting.

Can you set up a new dashboard from your phone app and see if it appears in your PC browser?

It really is starting to look like a bug in the app. AFAIK there are no special settings in the app or the HE web ui relating to dashboards.

Download the Hubitat app