Use Thermostat to control Thermostat Scheduler Mode

New problem cropped up this spring. I never had this issue before. I have a Trane Model TZEMT524AA21MA Z-Wave thermostat. My HE is Hardware Rev C-5 on Version I'm using the Generic Z Wave Thermostat Driver. The issue is when I change the Mode on the thermostat, the Scheduler changes it back to whatever Mode is set in the scheduler at the next set period. How do I use the thermostat to set the mode in Scheduler so the Scheduler doesn't change the thermostat mode?

I'm not sure what you're talking about. The schedule does not include setting the Thermostat Mode. It tells what to set heating or cooling setpoint to. If your schedule is such that the setpoint would command heating or cooling, that's simply the result of how you have those setpoints set.

You can open the Manual settings section of Thermostat Scheduler, and set the Thermostat Mode there. There is only one other situation where Thermostat Scheduler touches the Thermostat Mode: When you have selected the option "Turn thermostats off when restricted" and are using Restrictions. Otherwise, Thermostat Scheduler does not ever set the Thermostat Mode, except when you do it from the Manual Settings page.

1 Like

Beg to differ. One of the first settings in Scheduler is :
Hope the image comes through. If mode is set to "heat", every time a schedule setpoint is run, the thermostat resets to "heat" mode even though "cool" mode was selected at the thermostat.

Show the entire main page of the app. What you showed is what I described above where you can set the mode on the page that opens if you click what you showed.

Are you talking about setting it to heat on the Manual page? Who is setting it to heat in that sentence "If mode is set to 'heat'..."? When you set mode in those manual settings, that is the same as setting it at the thermostat.

Sorry, can't show entire main page of the app. In order to see it all one must scroll and I can't take a screen shot of a scrolling page. Let me see if I can explain the issue again. The screen shot above is the first part of the Thermostat Scheduller setup. You must make a selection for each box as part of the setup. The box for mode has selections, (Heat, Cool, Auto, and Off). I selected Heat and all was fine for the winter. However this spring I wanted to change from Heat to Cool by using the thermostat on the wall, not the app. I changed the mode to cool on the wall thermostat but the HE App changed it back to Heat at the next setpoint change. I know I can go into the App and change the mode but why would I want to do that. That is what a thermostat is for, In the spring I may have to change the modes numerous times until the weather warms enough to keep it in Cool mode. As you can see I currently have the mode set to Off. If I change the wall thermostat to cool, the App will change it at the next setpoint time to Off.

You can take a screenshot of the entire page using Chrome or Firefox.

Not on my laptop. I can click on screenshot and scroll a web page and get an entire screen shot of the scrolled page however when I load the Thermostat Scheduler page and than click "Take Screenshot, I can no longer scroll the HE page to take a complete shot, only the page currently showing.
I still want to be able to select mode at the thermostat on the wall and have it change the mode in scheduler, not the other way around. My wife will not boot a laptop, log into HE, migrate to app than scheduler to change heating system from heat to cool or off to cool.

Was able to add 3 screen shots together for this picture:

Did more testing and have additional information on issue. I could not get thermostat out of heat mode until I put "Thermostat Scheduler" in Restricted state via a "Virtual Vacation Switch" i have on a dashboard to allow me to stop the scheduler while I'm away and want the thermostat to remain at a set temp. With the "Scheduler" restricted, I am able to set the mode on the thermostat to "Heat", "Cool", "Off" and "Auto" at the wall thermostat. I'm also able to set the thermostat mode via the device thermostat page using the "Set Thermostat Mode" button :
image only. None of the other "Command" buttons have any affect.

I wonder if I have a similar confusion with thermostat modes. I am using Thermostat Scheduler to control heating and cooling. I use restrictions to allow changes to the thermostat only when in Day, Evening or Night modes so when Away, the AC does not run.

When I look at the thermostat during the day, I see that it is in Heat mode even though I manually set it to Auto mode and the temperature is approaching the Cool setpoint. A quick at the logs shows:

I am unable to explain the third line which shows the setting to Heat in the late evening (at a time which corresponds to the transition from Day to Evening times). What restriction is ending at that time since all times are outside the restriction (which is only for Away)?

Am I missing something with respect to the setting to turn off thermostats when restricted, which I would expect to be when the Away mode is set?

That mode is coming from the thermostat itself.

I have what seems to be a trivial issue. I am new to Hubitat so forgive me if it sounds stupid. I have connected 2 thermostats to Hubitat. 1 is Honeywell t6 z wave and another one is Honeywell D6. I have created the schedule for both and created a dashboard for both. I can control both through the dashboard via Internet manually but they do not seem to operate on the schedule. I have retraced my steps number of times and everything seems to be correct but I can not get them to work on schedule. Please help.

You will have to post a screenshot of one of the setups for Thermostat Scheduler.

But under "Select Period Settings" there are columns for Fan and Mode. Is that "Mode" not the Thermostat Mode? I note that when I click on an entry under either column, the page shows a few circles of green dots running around for a few seconds, then nothing happens. Why are we shown these two entries that act like buttons but do nothing? Please don't show them if I can't change them.

What I want to do is set "emergency heat" mode on the Wake time period, because I want the house to warm up quickly and my T6 is incorrectly choosing the heat pump even though the waking set point is well above the Droop limit.

Is setting Thermostat Mode not possible with Thermostat Scheduler?
Should I be using Rules instead?


Could you please show a screenshot of the Current States from the device page for this thermostat. What type of thermostat is it?

1 Like

This is my modified version of thebearmay's version of bcopeland's v1.2 "Advanced Honeywell T6 Pro Thermostat" driver from github. Maybe the Scheduler is using different commands? If you point me at the source to the Scheduler, or point me at the list of commands it uses, I can adjust my T6 driver to accept those commands.
EDIT: Note: I can change the Fan and Mode under Control Thermostat Manually -- I just can't set either field under Select Period Settings. Under Select Period Settings, clicking on Auto or Mode on any of my Period lines just causes a few circles of green dots for a few seconds, then nothing changes and I don't get offered a menu to set anything.

The driver has not been updated. For now, you can fix your device with these steps:

Thanks for the detailed explanation of the problem. I fixed my copy of the driver to configure the supportedThermostatModes with double quotes around each comma-separated item and that allowed the Scheduler to work. (Curiously, this bcopeland driver went to some trouble to remove any double quotes from the String version of the internal List of attributes. It was easy to reverse the code to add the quotes.)

Here are two suggestions for Scheduler enhancements, either of which would have avoided this support call:

  1. (best) Accept the comma-separated values with or without quotes. ("Be liberal in what you accept - Postel" Robustness principle - Wikipedia )
  2. (second best) Generate an error message (complain about the missing quotes) when the Scheduler can't parse the supportedThermostatModes.

In any case, thank you for very useful information that helped work around the limitation in the Scheduler. Our house will be warmer tomorrow morning!