Upgrade C8 to latest firmware last night, bricked device

I upgraded to the latest firmware last night via the web interface and it hung on install. I left it hoping it would complete, however it never recovered. The C8 that I bought in September 2023, now has no status lights. I read the forums here... I tried different power cables, different power adaptors rated for correct voltage, different power outlets, different Ethernet cables, different ports and even different 'please please please dances' and nothing. I did reset via the little round hole at the back but still nothing. The odd thing is that I can see network (orange only) connection when I plug it in, but no such luck seeing any connection when I log into my Modem and look via connected devices or mac addresses.

I can't think of anything else. I did look to see if it switched IP addresses but it isn't connecting at all. No status lights. I didn't expect a software upgrade to grenade a device that is only 6 months old. (Or in reality... ANY device really). Any hope? Any ideas? I have most of my lights in my house using rule machine to work on inovelli switches so I'm down to having to turn things on and off with my hue app (lights are hard wired to have power as this old house has no neutral wires).

So... am I buying another disposable hub, or does someone have a secret I haven't figured out? I almost wonder if I can buy it from Europe and get more then 90 days of warranty.. (ponders).

Thanks, I hope I'm some sorta freaky one off over here and this doesn't happen to anyone else. Just thought 'hey new update why not'.... spending Easter trying to figure out what happened wasn't the update I was hoping for! Take care everyone, and if you made it this far, thank you for reading my novelette and I hope your day is a great one!


1 Like

see here maybe >
Also .. Try rebooting your home Network .. and try this ..
( could be or sounds like its not getting a ip ? ) From router.

Network Reset

  1. Turn the hub over and locate the recessed round button just beneath the surface of the case (pictured below).
  2. Use paper clip (or other small, blunt object) to press and hold this button for at least 7 seconds.
  3. When the LED on the front of the hub blinks, release the button.
1 Like

If you have no led lit on the hub then I would say something serious is going on.
I know you have said you have changed the power 'brick' but can you check that is actually outputting a voltage.

Failing that, I'd would raise a warranty ticket.

I know it's the easter holidays so there may not be much of a response from the Hubitat team but I'll tag a couple of people to see if they respond.
@bobbyD @support_team


Thanks WarlockWeary. I rebooted the home network multiple times. I also have (unrelated) a new router coming that 'maybe' will give me more insight. I think I have my old nighthawk around here someplace too I can try.

Tried 7 seconds, tried 30 seconds... no go.

No LED on the front blinks.

So no lights at all ? Just when powered up get a quick yellow/orng ?
then NO LIGHTS ?

I think past 90 days it's outside warranty.

It's USB-C a little tricky to test, however it powers all other USB-C devices. I think at this point I may as well take it out of the case and run a multimeter on the pins to see if anything broke. However, it literally was working, update, not working... but I'm not beyond thinking somehow something physical 'could' have happened. Also... the orange network status doesn't light up until the unit is plugged in... so... it's doing something when I plug it in.

Thanks for the reply.

so the orange light stay on ?
but never get a blue or green ?

no light. Ever. :frowning:

ok then .. all you can try is a different usb brick .. one that has 2amp or more is best.
Bummer terrible that this happened on a holiday / Sunday
may have to put a warranty claim IDK ..

No LED light means hardware failure and the software never loaded...

also .. maybe the light went bad .. can only hope.

Go here see if it see it ? : https://findmyhub.hubitat.com

Yeah... perhaps somehow there was a hardware issue somehow... and updating it caused it to choke midway with no recovery? I dunno. I mean.. no light... and has power.... to me that feels like it's beyond recoverable. I'll order a new one come Monday or Tuesday. The warrenty states 90 days.

Any advice if I should go to Pro? When I replace something and there is a chance to upgrade I tend to... but I really hope this is the last time for a few years I have to replace this. It's amazing how you get so used to things just happening, like now I'm walking into a dark basement.. so used to the lights just being polite and being there for me. Anyhow, not life or death... just money and hours of setup.

Cheers guys.

I guess the guys like the new pro .. it is faster ..
see here : Review / perspective on C8 pro

If you do decide to get into hub, I would definitely pay for the hub protect
You get full backups. and extended warranty Totally worth the money.!

Thanks. So my solution was to take apart my C8, sigh, and buy the C8-Pro and get the extended warranty. Appreciate the help... now to remember all the things I had before. I did do a big intake when it said 'updating to latest firmware'. Ugh.