Updating Preferences for a device

I am new to Hubitat and I am having difficulty updating Preferences for any of my devices. So far I have added GE/Jasco switches (both on/off and dimmer) and a Fibaro water sensor. When I first add a switch to Hubitat it uses the Generic Zwave Switch driver, I change this to a specific GE/Jasco driver. I can't seem to update the Preferences very easily (the main preference I want to change is the LED light on the switch to be ON when the Switch is ON, as opposed to the default setting). The only way I have been able to accomplish this is to change the preference in the specific GE/Jasco driver then go back to the Generic Zwave Switch driver and then go back again to the GE/Jasco driver at which point the Preference for the LED on the switch is the way I want.

I thought this might be a specific problem to the GE/Jasco driver I was using, but I am having the same problem with the Fibaro water sensor. When the sensor was first discovered, Hubitat added the device using a Generic water sensor driver, I changed this to the Fibaro water sensor driver and it then lists lots of Preferences that I would like to change. When I change them and click "Save Preferences" it doesn't change them on the device. Here is a picture of my log:

Any help would be appreciated.

I'm unfamiliar with those switches...

That shouldn't have happened so if you post the information shown in the data section Hubitat can add that fingerprint to the driver so it gets identified correctly for other users in the future.

Most battery operated z-wave devices sleep so the driver can't send any commands to the device until the next time it wakes up which is why you see those warning in the logs.

Enable logging again, save, and then open the device and push the tamper switch which should wake it up. (assuming you have the ZW5 model)

If you have the older model then it doesn't send a wake up notification when it's manually woken up so you have to press that tamper switch immediately before clicking save.

The water sensor is plugged in, so it shouldn't be going to sleep. It is the newer ZW5 model and I see it connected to Hubitat as a Zwave plus device. But I did try pressing the tamper switch to no avail.

2019-03-15 12:22:01.748 pm debugDevice, parse description: zw device: 07, command: 7105, payload: 00 00 00 FF 07 00 00

I removed the Fibaro water sensor from my Hubitat and then Added it again. It did not recognize the device as anything other than a device. The log is shown above. The device was added as the type: "Device" and the info provided is:

  • deviceType: 2817
  • inClusters: 0x5E,0x22,0x85,0x59,0x20,0x70,0x56,0x5A,0x7A,0x72,0x8E,0x71,0x73,0x98,0x9C,0x31,0x86
  • deviceId: 8194
  • manufacturer: 271

@Stephan.J, (Stephan H here by the way :wink:)
After you change any driver you should hit the Configure button on the device page. Then refresh the page and try changing the preferences.

1 Like

DAMN! You beat me! :stuck_out_tongue: I was just starting to type when your reply popped up. hehe

1 Like

That is one of the first things I tried. I think the fact that Hubitat does not recognize the sensor as a Fibaro water sensor off the start, is part of the problem. Is there a way to edit the Fibaro driver that would allow me to have Hubitat recognize the Fibaro water sensor as a "Fibaro water sensor" and apply the correct driver from the start?

I think you can send this info to @mike.maxwell and he can add it for a future platform update if it's not already in the driver. But is it really that much of a problem? Not trying to minimize your report that the hub isn't working exactly as expected, but once you know how to manually set the right driver, it only takes a few seconds to correct.

I have no problem manually setting the driver. My problem is described in the original post. When I manually set the device to the fibaro driver, I am not able to set any of the preferences. I need to be able to do this.

Oh, sorry. I thought your issue was resolved by changing the driver. Just to confirm, after changing the driver in the device details page, you saved it and then clicked the Configure button to send the driver details to the device?


Looking at your log in the OP, I'm confused. This is your Fibaro flood sensor you're referring to? The log says CO/Smoke. Are you sure you selected the Fibaro Flood Sensor driver?

Yes, It is most definitely a Fibaro Water Sensor, I use it to sense when my smoke/co alarm goes off. The only reason the log says Smoke/CO is because that is the name I gave it, due to its purpose. Hubitat allows you to name the device anything you want. If you want I can change the name to Fibaro water sensor so the log will show fibaro water sensor instead of Smoke/CO but the name makes zero difference to the driver I applied and to its operation. The device is most definitely a Fibaro Water Sensor and I most definitely applied the Fibaro Flood Sensor as the device.

I will try removing the device and adding it again. (for the third time).

That might do it, but I'm wondering about the / in the name. Maybe just replace that with an _ and see it that is making the difference. You normally shouldn't change the Device Name. The Device Label is for you to customize and in your device list, the Device Label overrides the Device Name where display is concerned. Internally the system keeps track of the Device Name.

It's joining without the battery command class which is why it's not getting identified so that fingerprint will need to be added to the built-in driver.

If you don't need it to act as a repeater you should unplug it and join it while powered by batteries. That way it will act as a powered device when plugged in, but still be able to act like a battery device if you lose power.

1 Like

Sure hope that's not true.

I've changed virtually all of mine by now. In fact, I just did it to my latest addition: Aeon Recessed Door Sensor 5

20 mins ago, it Joined as a Generic ZWave Contact Sensor with that in both Name and Label. I've changed both. Name now has "Aeon Recessed Door Sensor" and Label is what I want to call it.

There was something that Chuck mentioned about why. I think it might only relate to the names for Link to Hub, but as a general rule I don't change mine. I'm probably mistaken.

I'm pretty sure everything internally uses device Id and I change the device name on mine all the time and have never had a problem...

1 Like

Why do you guys change the device name, when you can just change the device label and it overrides the device name in the list?