Updated to Static IP then Find Hub can't update to new IP

When I initially setup the hub, I was letting it use DHCP IP, and got assigned to

Then after I tested adding some device, and confirmed I will use this and update it to an IP in my static IP range ( ), everything seems working correctly too.

However, next I tries to register the hub so I can connect to cloud service, and the http://findmyhub.hubitat.com/ page only knows about the IP, and I tried all three method and can't make it find my hub on

I looked at the browser console, and it looks like only the "Local IP address scan" is actually trying to look at my local subnet. But even though I was able to view the logo image it tries to access in my browser ( ) , the webpage was having issue getting a 200 response. It is throwing a CORS error due to the findmyhub site is using "strict-origin-when-cross-origin" policy but it is trying to load image from my local IP.. Did the CORS setting somehow changed? Else I can't figure out how this feature ever work in this config..

After all the technical info..

How do I update my hub's IP info from the find my hub page? I assume it is mapping either by the MAC address or Hub ID, but I can't seem to get the find my hub to update that IP address just using the website? It looks like some info is already stored in some DB on the server side and I can't use the find my hub page to update that info.

If I need to get in contact with a support person.. how do I reach them?

Reset your hub to DHCP as described in the documentation (linked below). Then reserve an IP address in your DHCP server for the hub.


1 Like

Is there no way to update this IP with static? My router's MAC address binding is rather finicky and I wish to use static IP when I can. ( also to keeping the dhcp pool clean ). This is not a case of static IP not working, it is about find my hub not able to scan my subnet to locate new IP.

Does DHCP does anything different to update that IP?

Yes, it provides the hub with the IP addresses of working name servers. Did you configure that while setting a static IP? Without that, you hub isn't connecting to Hubitat's cloud.

If you use a static IP, set multiple public nameservers, such as:,,

1 Like

The page did have a DNS override there (,,,,, and I was able to do network test with working result.. So not sure which step is wrong there.

But thanks to your pointer, binding MAC and changing it to DHCP did fix it, and I can see the correct IP in the find my hub page now.
Now I can set it to static again..

BTW if any Hubitat staff is watching, it might make sense to update the CORS config for that find my hub http server config.. as of right now I think the scan local IP feature would not work as expected.

Retype the DNS servers and hit save.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.