Update to 2.2.6.134 from 2.2.6.129 stuck

Has been on "applying update" for over 20 minutes. Is there a safe way to break out of this?

If I recall correctly, I have seen posts of people where for some reason it took around 40 minutes... Not something I have ever seen myself.

Do you have a C3 or C4 by any chance?

1 Like

This is on a C7 - my experimental hub. I finally pulled the power for 30 seconds and repowered. It came up with a new IP address, and says it is now on platform xxx.134 - so apparently the update took. All my devices and rules are present. I'll just watch it for a few days.

1 Like

Ah! That would make sense. Have you considered reserving an IP address for your hub on your DHCP server?

Note that you can also access your hub via Hubitat.local - though if you have more than one, Iā€™m not sure how it determines which one it connects to in that case...

1 Like

Always best to try reboot or shut down from the diagnostic tool if you can, before pulling the plug at the wall.

https://docs.hubitat.com/index.php?title=Hubitat_Diagnostic_Tool

2 Likes

I'm no expert on networks, but I'm learning. I just added an Asus AC3100 last week. Took some time, but I did get everything working. I "thought" I had both of my hubs on reserved IP addresses. I'm pretty sure I have it set up now. I have 5 hubs and I've learned how to find them over the past few months. I can usually locate them with their MAC address if nothing else. find.hubitat.com worked tonight too. Thanks for your reply to my SOS.

1 Like

I agree. But when it is stuck, how would I access :8081? Could I have just opened another window and tried to get to diagnostics there?

Yes. The tool is, for very good reason, independent of the platform.

1 Like

Thanks - I'll try to drill that into my memory.

Download the Hubitat app