Update Issues to and above

Currently I am running a C7 hub for ages without issue. Recently when I tried to update to I found that I was unable to enroll or exclude any devices and had to roll back to and completely exclude every device and re-enroll everything. Today I tried updating to and all of my devices vanish as If I just registered a new hub. I had to roll back again to and all my devices returned. Any suggestions?

Take a backup and save it to your PC.

Do a Soft Reset and then restore the just saved backup.

Try the upgrade again.

The thinking is that v2.3.2 and 2.3.3 have slightly different DB structures and your DB may be corrupt and thus not making it through the migration that occurs during the upgrade process. The Soft Reset process cleans DB issues.

The other choice is to: take the backup, Soft Reset and NOT restore. With an "empty DB", do the upgrade and THEN restore the saved backup.


Yeah, restoring from a backup while running 2.3.3 should do the trick.

Yes, 2.3.3 uses a different database structure from 2.3.2 or earlier. It does a one time migration, but if that fails in some way, the "migrated" marker stays around. Restoring from a backup resolves it.


Thank You! Thats what it needed, Issue resolved.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.