Update failing, download failed


I’m having trouble getting a c-5 hub updated. Running, and I’ve tried numerous times with all the interim updates, to no avail.
Currently failing to get into it.

I had assumed it was the woeful broadband, currently about 200kbps. But it is there, sort of.
I’m doing it all remotely, either with Hubitat remote access, or Remote Desktop to a local pc on site, which is Ethernet to the router.

Anyway, the update downloads either all the way to 100%, then thinks about it, and says download failed, or gets most of the way, like 85%, and b says download failed.

I have rebooted, but not soft reset. It otherwise behaves okay, afaik.

Any suggestions, please?

Is there anyone local to power off/on the hub? I have mine on Kasa switches so I can remotely shutdown, then power off and power back on. It has saved me many times.

Ahh, alas not. I was there a couple of days ago. Ironically, partly to power cycle the broadband router manually. And I was thinking I should have the router on a Zigbee socket so that I could automate power down, wait a couple of minutes, power up.
So now I need the Kasa socket on the Hubitat too!

In the absence of physical access… anything I can do?

Ooh, just went to have another go remotely, and I guess that last time I set it off, it worked! It’s updated at last.
I see also that the broadband has improved a little: 800kbps. Whether this had any impact, I know not.
Anyway, problem gone away for the time being :slight_smile:

One of the issues you should check when you see this is your ethernet speed. If it's set for fixed 100, change it to auto and make sure you're not using jumbo frames anywhere on your network.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.