Unwanted debug log- how do i disable?

Getting masses of (annoying) unwanted debug logs for a device. As far as i can see i have "enable debug logging" disabled for this device and all its child instances.
I can only guess it might be "rule machine" creating the logs but i see no option to control debug logging in there. Any tips or advice appreciated. thanks

If you click on the blue "debug" text it will take you to the device / app that raised the log, though I would expect it to be device 257 in this case. If it was RM, then I would expect to see an "app" reference for RM on the left hand side, and the "debug" link would take you to the RM rule. That should at least clear up which "thing" is generating the logs.

Is this a Community developed driver?

A device running twice/minute with some events a few milliseconds apart, would be cause for concern. Before you figure out how to disable the logging, I would validate that the device should be firing events that often and is not some rogue device that has gone bad.

Click on the degug tag as @sburke781 suggested, then share the driver type (also scroll down to scheduled jobs section and see if there are any tasks listed).

1 Like

Clicking on the "device 257" link does not take me to the actual device. But i know what device it is.

It's using the "Jasco Z-Wave Dual Outlet" driver, the only driver i found that can control the two relay outputs of this boiler-control unit.

I have a refresh app running every minute, hence the busy logs. As said, its not the best driver but the only one that does the job but needs regular refreshing to keep the status current in HE. I tried the polling-app but it didnt work as nicely. I have the refresh updating a few z-wave devices that are not "z-wave PLUS" in order to maintain communication.

So i know its the rule-machine app running every minute but cant see how to disable debug logging for this event. Its not critical, just annoying when i want to scroll through the logs for diagnosis reasons.

I originally intended to post a clarification to my comment that depending on how the developer handles the logging, it can appear to come from a parent device or from the child, perhaps it is funnelled through a parent device in this case.... (I know I have done this in one or two drivers I have developed....)

1 Like

It's a device event for sure, check both the parent and the child to make sure debug is disabled. If clicking debug takes you to parent device, then check the "Component Devices" section and disable the logging for any child devices.

Just keep in mind that polling a Z-Wave device that frequently can cause latency in your Z-Wave mesh, especially if you have more than one device doing that.

thanks. the main "parent" device has the "enable debug logging" option, as does two of the child devices, all set to off. (the child devices are 257-1 and 257-2)
There are two other child devices, which i think are effectively aliases of the two child-devices but these dont have "enable debug logging" option available and are device 18-1 & 18-2.

In case I missed it, what is the driver? A screenshot would be useful...

1 Like

The logging comes from device 257. What driver is that device using?

1 Like

You need to click on the blue box with the word "debug" inside it. Or in normal entries the white box with "info" in it

1 Like

driver in use is "jasco z-wave dual outlet"

clicking on the blue box reveals this:

Removing extra log from next release.. Thanks


cool. thanks for the info