Unstable Z-Wave since 2.3.X upgrade

I was wondering if anyone else is experiencing very unstable Z-Wave networks since the 2.3 upgrade. I realize that nothing *should be different, but my mesh was rock solid on the last few 2.2 releases and it has been nothing but headaches since 2.3. I'm talking like virtually unusable.

Here is maybe an illustration of what I'm experiencing. I did a full power-pull reboot (to reset the Z-Wave radio) about 20 hours ago and I noticed that none of my lights were behaving correctly with the motion sensors. I decided I'd try to do a full repair to see what would happen:

Many of these nodes are literally 3-4 feet line of site to the hub. My free memory is about 364 per Hub Info.

Does anyone have any advice on what could possibly be going on? Only significant Z-Wave changes since the time on instability was 2 Zooz water sensors and a Zooz multirelay (of which I already had several on the mesh). 72 total Z-Wave devices split relatively evenly between battery and hard wired.

All that said, it does appear to come in waves - nothing will work at all for 5 minutes or so and then suddenly, things will start working again.

1 Like

This is generally not advised as it will only exacerbate the situation by adding traffic to a network that may already be suffering from traffic overload. The only time a full repair should be performed is when the controller (hub) is moved to a new location.

Post a screenshot of your complete z-wave settings page.


Can you copy and paste what it says here:

1 Like

If no devices are working at all, then some (all) start working it could be that devices in your system are demanding too much Z-Wave bandwidth. It takes a few misbehaving devices to bring your mesh to its knees. Check this post for more details:


What version of 2.3 are you using? I had problems with 2.3.130. No problems after that. Running 135 now.

Shutdown the hub from the settings menu, unplug power to the hub (at the wall not the hub) for 5 mins then power back up and see how it behaves. Also post a copy of your z-wave details page in it's entirety,

Distance is relative and often not the best measurement to asses the strength of a mesh network:

Introducing new devices into an established mesh can have exactly the outcome that you have described.

Have you tried excluding those devices, then run a full repair? If nodes still fail, you likely have one or more misbehaving devices (either going bad or at the edge of the mesh). Identifying which those devices are, is imperative in your efforts to regain Z-Wave stability. Unfortunately, the investigative work could be onerous and time consuming.

1 Like

Apologies for the delay. That didn't actually work, but I'm running 7.17

Thanks. I've tried this several times with no changes in behavior.

I'm always running the most recent version. Currently on and still experiencing the oddities.

Agree, and I don't typically run a full repair. Consider this a "last resort" action that I did because I was getting so frustrated.

I presume you meant Z-Wave details, if so, here you go:

I think you typed the url wrong. It's http://xxx.xxx.xx.xx/hub/zwaveVersion. (example: My hub returns this:

1 Like

Got it. Here is mine:
VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

This is a little off-topic, but something that I've frequently been curious about is what appears to be non-sensical routes (this isn't the typical "why isn't it going to the closest device" question). Here is what I mean:

Device 5B says that its route is 01->10->18->5B, but 10 and 18 are both directly connected to 01. So why wouldn't it be 01->10->5B OR 01->18->5B?

I thought that maybe it was a delay in route reporting since 5B is a battery device, but device 2E (AC-powered) has the same phenomenon with respect to devices 42 and 44.

There's lots of cases where the bitrate similarly doesn't make a lot of sense (the end of the line device allegedly has a faster connection than the repeating device(s) e.g. device 69's 100kpbs vs 31's 9.6kbps).

Back to the topic at hand: It appears that I have 1 device that had been set to report power every 24 hours (the infamous Zooz double plug); I've disabled power reporting. The other oddities are device 63, which I subsequently did get to report its route and device 64 which doesn't seem like it should be a problem as it appears to be working correctly, but I'm suspicious about maybe a bad pairing because the device class is wrong (it's a zooz leak sensor like the others in my setup, not a Samsung).

The likely explanation is that you cannot "sense" what you cannot see. The waves may be reflected by objects and even though two devices may be near each other, a stronger signal could be detected on a device that is further apart. Also Z-Wave devices are trying to hop the least number of hops to reach the hub.

Right, I get that, maybe re-read my curiosity question - I'm not talking about distance between devices, I mean that the reported route seems inconsistent. If we already know that devices A and B are routed directly to the hub, then why does device C hop to B AND A rather than just one or the other?

Yet another of the many elements that make ZWave routing a complete mystery is Time. At the moment a device is Included is when the hub starts its selection of a route. If at that moment, B wasn't directly connected, then routing C to B to A would make sense. It's after that that B became aware of a path directly, but the routes are already cast. The Hub has already passed the snippet of the route table to C. It's going to continue to use that.


Which also explains why you can plop a zwave repeater or two in the middle and nothing uses them.

1 Like

So at this point I have re-paired about the last 6 devices that I added to my mesh to see if it improves stability. Upon further investigation, it does seem like this all happened relatively close to the time of the 2.3 update, so that is probably coincidental rather than causal. I'll let you know if it helps at all after a couple of days.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.