Unbreak cmd-click on device name on /devices/list page

Currently, when you cmd-click on a device name to open it in a new tab, the browser ignores that and opens the device in the same tab. This makes it difficult to open more than one device page at a time. For example, if I want to enable logging on all my sensors, I have to manually click into and back out of each page.

This behavior is also broken on installedapp/list, and hub/edit, but notably not broken on app/list. drivers/list seems to do both: cmd-click opens a new window with the link as well as retargeting the current window at the link url.

MacOS, firefox

Same is true on Windows. Cntrl-click and shift click both just open the link instead of going to a new tab/window.

Surprisingly enough though, center click and right-click + open in new tab both still work fine. It's only the cntrl-click that is no longer working.

@durable-navy-blue-ot, have you tried a long-click (right click on a pc) + open in new tab?

I've noticed the same issue, at least with Firefox and Safari on macOS. Right-click (or two-finger click/tap or whatever the equivalent is on your input device) and "Open in New Tab" does work as expected but is more cumbersome when you have a few pages you'd like to open in the background. Middle clicking also sometimes works, but it is picky about exactly where you click (the blue text seems to be fine; elsewhere where a regular click would still work does not work, and Safari seems worse in general than Firefox).

EDIT: I haven't used a keyboard on iOS if that's what you're talking about, but I suspect the behavior would be similar with Safari being substantially similar between the platforms.

On an iOS device I'm able to long-click, and select to open a page in a new tab. Not sure if that's what you're talking about. A right click and open in new tab does work, if that's what you mean. I don't have a mouse with a middle click at the moment.

Isn't right click on a mac a "long" click since the mouse has one button?

This was a ritual ancient Mac users once performed to achieve secondary clicks when desired before the advent of modern macOS and multi-touch devices. :slight_smile:

1 Like

Well, I haven't used one since 1999. So forgive me. But with a Mac mouse, isn't that STILL the way? Or do mac mice now have 2 buttons?

How do you get multi-touch from a mouse?

And I think you're missing the big picture here.

I'm not missing anything. :slight_smile: Magic Mouse, Magic Trackpad, and trackpads built into all modern Mac devices are mutli-touch, and two finger taps/clicks are one way to perform a secondary click. (The older Mighty Mouse wasn't touch but also had two buttons, just not a seam in the plastic covering. Yes, the Magic Mouse has touch.) Ctrl+Click is another method. More multi-touch methods are available with modifying default preferences, and far more possibilities are available with third-party tools. The days of a one-button mouse have passed--but the default settings and appearance of devices still might make one think they haven't.

Anyway, not getting de-railed on this (so I'll not respond unless the OP has further questions): the point is that Cmd+Click doesn't work at all (I'd be curious if Ctrl+click is different on Windows/Linux -- oops, forgot this was mentioned above, and it is the same), middle-click is picky, and right-clicking is the most reliable way to make this work but also the least convenient. Not a big deal for me but, again, annoying if you want a few pages to start loading in the background or whatnot.

Ah, the reason it’s broken is that it’s using JavaScript to make the entire table row clickable. This has the unfortunate side effect of also making it impossible to copy text out of the row, such as the device ID β€” this is what bit me just now.

@gopher.ny @bravenel
Sorry to open an old topic, are you able to check why CTRL + Click doesn't open in a new tab on any browser on the Devices page but does work fine on all other pages like the Apps page for example?

I tried Chrome, Edge, Firefox and IE, all has the same behavior from what I can tell. I find CTRL + Click is very useful if I want to open multiple devices at once for testing or editing multiple devices. Only workaround is right-click then Open in new Tab which is much slow than doing CTRL + Click.

What comes up when you CTRL + Click?

This is what I get, Chrome on a Mac:

It opens the device I clicked on in the same tab. In Windows normally CTRL + Click opens in a new tab in Chrome but there must be something coded that is preventing that since it works on all other pages on the Hub besides the Devices page.

Do you mean Cmd+click, the standard Mac "shortcut" for new tabs? (If you're using a PC keyboard on the MAc, your modifier keys might be mapped differently, but with standard Mac mappings, Ctrl+click would be a right click and should do what Bruce shows.)

The Cmd+click shortcut does not work for me; it opens in the same window/tab, as if I never held Cmd at all. Middle click, which should be the same in my browser (Firefox on Mac--and really any browser I've tried) does work for me.

To work around this, if I'm only using the trackpad, I usually "right click" (two-finger plus click) or Ctrl+click to get the menu, since I can't seem to manage to do this any other way. But I do agree that it would be nice not to have to use the menu for this--less clicking and less moving around!

This likely has to do with the DataTable component those links are in. There's nothing special about a device link in itself. The issue will most likely be addressed once we get to UI redesign.


I forgot to reply earlier, this is for Windows only. Ctrl + Click (left click) opens the link you clicked on within another browser tab. I don't own a MAC so no clue if MACs has this option or not.