Unable to update C7

Hi, I'm having trouble updating my hub.
I have only had 1 successful update since I got my C7 about a year ago. Now it is really starting to concern me.
I've tried the restarting, soft-resets, different cables. No luck.
Currently running

I have reached out to Hubitat support, They referred it to their engineering team a month ago, and I haven't heard anything back since, so am hoping the community has some guidance.

Two things that we have concluded:

We have checked your hub and can confirm that it is online and connected to the cloud. We don't see any reasons why you would not be able to update the hub.


the link they provided, reached a 404 error:

How else can I troubleshoot this? Any help is appreciated. TIA

If you go to the Settings menu, and the Diagnostic Tool what happens if you do the "Download Latest Update" in the Diagnostic Tool menu?

I have no Diagnostic Tool option in the settings menu. Is that nested elsewhere?

Oh crap, forgot they added that in an update after 2.2.4.

So at the end of your hub's IP add :8081 [192.168.x.x:8081] and see if the diagnostic menu appears.

EDIT: Be sure to back up the hub before you do anything just in case you need to revert.

You might also read this thread, specifically look for Gopher's posts starting part way down the page, apparently this worked for others:


Thanks @neonturbo. Although my steps differed to those in that thread, I found that "revert to previous version" in the diagnostic menu gave me the option to download the latest version, and I hit update from there, rebooted the hub and now we're cooking with
Thanks for your help! :slight_smile: