Unable to setup new hub

Hi, new Hubitat C-7 user here. Having initial setup issues. The automatic hub discovery does not find the hub, but if I give it the IP address in the advanced discovery it does locate it. Clicking connect though just bring up and "unable to connect to server" page. I am able to get the diagnostic page at port 8081 to load. I have tried everything on here (reboot, soft reboot, update version, etc.) but still no luck getting what I assume should be the main web interface to load. Side note on the version, it says I'm on version which doesn't appear to be the latest. When I run the version updater, it says "success" and counts up to 100% on the download but then never re-directs and also doesn't appear to be actually updating.

Any thoughts on what I should try next? I opened a support ticket but figure since its the weekend I won't hear back until Monday.

What happens if you just plop the IP address of the hub into your browser? Does the UI come up?

@bobbyD sounds like this one could use an assist…

1 Like

Welcome aboard. You might be surprised :slight_smile: Please check your email.


Hi Brad, thanks for the quick reply. I've tried just putting the IP into the browser as well, still nothing. only page that works is IP address with :8081 at the end. Are there any other port numbers or sub directories I can try after the IP address or should the IP address take me to the main page. This the first Hubitat I've ever used so not sure what expected behavior is.


Wow thanks! Looking at your email now, will try out these steps.