Unable to remove zwave device on C5 hub

I needed to remove a Zooz tilt sensor so to update the firmware but it would not remove so I did a force remove. I then tried to remove a Aeotec Smart Switch 6 to verify the exclude issue was with the device or the hub. It also would not remove. If I select the device from the Devices tab then click Remove nothing shows in the log that the exclusion mode was enabled. The only way I can see any activity in the log is to go the Add Device and from there click on Start Z-Wave Exclusion.

The exclusion process for the Aeotec Smart Switch is to just press the Action button which I have done while in the hub is in the exclusion mode but it will not remove. I would like to be able to remove devices without having to Force Remove each time. I am running ver on a C5 hub.

It is normal for the "Remove" button on the device detail page to not log anything; that is a node-specific exclusion, a different process from the general Z-Wave exclusion that the "Start Z-Wave Exclusion" button on the Add Device page does. Besides working a bit differently under the hood, the node-specific process just happens to not write anything to logs when the process starts or stops. So, that alone isn't a problem -- but the fact that it doesn't seem to work for you the normal way could be.

Are you saying it does work via general exclusion? I don't see any mention of that, just that you were able to see logs that way (again, just a coincidental difference). If the device didn't remove either way, it's possible you had a dead battery, a reset device, a range problem, or some other issue that prevented regular exclusion from working on the device, but I'm guessing you might have considered those factors already.

If it only removed via general exclusion ... then that's odd. Maybe someone with a C-5 hub can test, though I haven't seen any similar reports. I don't have any Z-Wave paired to my C-5 anymore, but I paired a spare device to my C-3 (which runs the same Z-Wave stack, just using external hardware, and I'd expect to work the same) and was able to exclude it normally.

If that all old news to you, I might try rebooting your hub or even shutting it down and removing power for 30 seconds or so (not normally a thing the C-5 needs, but if you want to pretend it's a C-7 that early users in particular sometimes had to fully restart the radio on, it won't hurt :slight_smile: ), then trying again. If nothing else but a general exclusion does work, I'd suggest that over a Force Remove given that you don't risks "ghosts" that way, which can be problematic on any network and likely at least early-firmware 700-series SDK controllers more than the 500-series one on the C-5, but still something to avoid if you can.

I have had noting but trouble recently with getting devices to remove. I have tried it with all the different options within Hubitat and have even been working with Zooz and Aeotec but nothing other than the Force Remove will work. I have moved the hub so it is located within 6' of the device but that did not make any difference either. I have been able to add Z-Wave devices no problem it is only the remove that is having issues.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.