Unable to Execute Maker API Local URLs

As the title says I'm unable to execute commands via local url. I get the following message:

{"error":true,"type":"AppException","message":"Not Found"}

Here is the local url:
http://[IP REMOVED]/apps/api/200/devices/470/on/?access_token=[TOKEN REMOVED]

The cloud URL works perfectly. Here is the cloud URL that I'm using:
https://cloud.hubitat.com/api/[URL PATH REMOVED]/apps/200/devices/470/on/?access_token=[TOKEN REMOVED]

I'm using the given url convention from the Maker API page. I have tried different browsers, changing syntax on the "on" command, testing http vs https, etc but nothing seems to work. Any idea what my issue could be?

Appreciate any assistance.

I'm thinking you may not need the forward slash between on and the question mark...

Just tested that theory and it worked, I got the error with the forward slash included, but it worked without...

So you need:

http://[IP REMOVED]/apps/api/200/devices/470/on?access_token=[TOKEN REMOVED]

1 Like

Yes that fixed it! Thank you so much.

It seems to me that the syntax shown on the maker API page is confusing or unclear if a secondary command is not used. It is showing a forward slash:

You're right, would be good if the slash could be shown inside the square brackets....

What's even stranger is that the cloud url still works when you use the unnecessary forward slash

1 Like

Download the Hubitat app